Losing faces- kicking my a** for 14 hours--Help!

Hi. I get the frustration and problem you’re having. I spent months, not 14 hours with similar issues. I was off by .000007" from edges intersecting !!! So, here’s what I learned. Put the dimensions into the box to set a line length, not snap. I work on machine parts, so .001" is large for me. You’re building a wall of 2 x4s but still, the CAD is dead accurate, or not !!! So, make your wall 8 feet, not draw a line and let it snap. If it snaps 1/64" short, you won’t have a “closed volume.” I’ve done the triangle thing, and only after zooming in from outer space to the pixel level and twisting all around with the space mouse did I see the tiniest of gaps. Bonkers. So, you may wish to set your “snap to” so something like 1/2" - that you’ll be able to see, given the size of building elements. I hope this helps you.

Taken that you are talking about length snapping, you better don’t set it to any size at all. Best is to disable length snapping! And then either let SketchUp’s inferencing to existing geometry do the job or overrule this by numerical input.

I see:

I have yet to see this happening, a coplanar face formed by non-coplanar edges.


Just turn it off! The basic problem is no matter how small or large you set the the snap it can force a snap to something other than an endpoint.


It happens, if the snap is within the sketchup tolerance. And that tolerance can be quite tiny and large depending on the scale of geometry and the ridiculous snap override.

Try this, draw a square 1000m, 1000m, move one corner up by 1m, then scale everything down by .001 and check the face and vertices.
My guess is you’ll see a flat face without any hidden geometry but the one corner will be off 0.
If I am correct you are seeing an analog demo of the digital error.

Sorry but it does not. I know what you mean and getting the surface with no hidden line (not a face) is quite easy.
The surface allows you to draw new geometry starting from “On Face”. Then measure the location of the new “On Face” vertex. It will be off somewhere in between the zerro vertex and the onerous vertex on the opposite corner of the surface. Meaning that the surface wasn’t flat to begin with.
SketchUp says “On Face” but in fact there are an infinite number of locations on the surface that are off. The surface is virtually split into two flat areas with no hidden line inbetween.

Yes I know the forming of a face by no coplanar edges is a total nonsense, but we are talking about the distorted twisted geometry that somehow happen but nobody wants.

To show this face and more importantly how to correct the geometry see:

A, B and C are coplanar while D is off (this) plane by 0.01mm
Hidden geometry is visible, see the horizontal edge on the side.
The rectangle itself shows no hidden diagonal.

Correction of the geometry that supports the face:

  • delete the face
  • draw diagonal AC. Two triangular faces will form.
  • with nothing selected but the ‘Move’ tool drag D along blue and inference it with face ABC. D is now exactly coplanar with ABC.
  • Delete the diagonal AC.

Not sure what you mean. Box demonstrated on my example near the top of this thread that this is exactly what happened–the majority of the faces filled in despite the non-coplanar edges (resulting in the spiderwebbing), and I don’t recall originating any lines from the face as in your example, or any lines crossing through the faces. There were many instances where points “A,B,C,and D” were not coplanar, yet a face formed. Unless you’re suggesting that existence of a face is not synonymous with being coplanar–I don’t have the technical knowledge to comment on that, but would be interested if Colin would agree. Or perhaps I’m not understanding your point at all.

Are you saying that the snapping resolution only applies if you’re in drawing in “virgin space”? That either the presence of a nearby point or even an inferenced point can override the snapping resolution? That would seem to defy one of the reasons for defining snap resolutions. If, as DJRonFinlay suggests, I set to a very course resolution to facilitate fast, course drawing (which makes intuitive sense), I can be lulled into a false sense of security and have my drawing hijacked by nearby geometry and inference points?

It’s been said so many times now. Turn enable length snapping off.

1 Like

I’ll try to explain what happens when some vertex of a loop is inadvertently moved within SketchUp’s tolerance to still support a face, although now the face in fact is split into two areas without the dividing hidden diagonal. It is a not coplanar surface.

Draw a rectangle 10m x 10m on the ground plane
Move one vertex 0.01mm up along blue. The face remains visible but can’t be coplanar. Measuring locations on that surface reveal infinit different Z values, all between Z=0 mm and Z=0.001 mm.
You can delete the surface. It will reappear (as a surface) when redrawing one of the bounding edges. SketchUp indicates these surfaces as “Face”, unfortunately. You need to correct the geometry to avoid issues when continuing.

1 Like

Here is a file to entertain you. The non-coplanar edges allowing a coplanar face issue, is usually the example that the other talked about, where dividing a should have been coplanar face can leave you with two distinct faces. Interestingly, it happens more if the geometry is far from the origin

In this model, which is a SketchUp 8 file (I tested to see that the problem has existed for that long), notice that the window is empty, and you can see through to the sky. Now double click on the frame, and it no longer cuts through the wall.

See if you can find the one or two corners that need fixing.

holeinthewallissue.skp (2.2 MB)

I’m trying to understand how snapping is intended to work so I can choose where or where not to use it. Just repeating “turn it off” isn’t very helpful.

Honestly, this feature is so commonly misunderstood and is the source of much frustration. I often think it should be removed, or at very least made off by default.

Length snapping controls the length of lines (and objects). If you have it set to 1’ increments (I’m using a big number to illustrate a point) then you will only be able to make lines that are in multiples of 1’. So you can draw a 1’ or 2’ or 30’ line, but not a 2’8" line. It does not set up an invisible 1’ grid of snapping, so you can still start a line anywhere in space, therefor objects do not line up on any sort of grid by default, but once started things can only be made in increments of 1’. This snapping applies to all the tools, rectangle, circle, push/pull etc. This setting can be overridden by the inference engine if it detects an inference point to snap to. So in theory with snapping set to ON one could still make lines that are not 1’ by using existing points to snap to. A triangle for example, the first line would be say 6’ and the other side 4’ and the hypotenuse would be whatever length necessary, but you would have to make the hypotenuse after the other two lines so the inference engine could help you make a line in something other than 1’ increments.

In practice when length snapping is set to ON it often introduces small errors in the model. When set to 1/8" for example and when drawing a line that would naturally need to be 8 3/64" to close a loop, It can be very hard to notice if you are truly snapping to the end of an existing line, or snapping to a line length of 8 1/8" and are only coming close to closing the loop the way you intended to. Often the difference between being “square” and being within an increment of the length snapping are very close. The differences are too hard to see and it’s too easy to go right on modeling continuing to reference the initial error and compounding it with more small snapping errors thereby building chaos into your model.

It really serves no function other than to occasionally give you false a snap that does not line up with the rest of your model. Very rarely I will use it by setting it to 10’ or something to make it easier to move existing things around in a grid for visualizing spacial arrangement problems. But for any modeling, it should remain off. Entering exact dimensions by typing and using inference on existing geometry is the path to a clean square model.

or, more succinctly,


Your file isn’t helpful. You are introducing a perimeter that has four vertices that aren’t coplanar.
The connecting edges support a surface that is somehow extra distorted by a ‘Glue to’ component with a cutting loop that itself seems to also be not coplanar.

If you rotate the wall flat on the ground, three vertices are zero. The other has a z value other than zero.
Measuring locations on the wall surface reveals all kinds of z values between zero and the fourth z value.

Furthermore, double clicking the frame proves nothing. You temporarily open the ‘Glue to’ component. It temporarily doesn’t cut the face. Exit the component and it cuts again.

You are right, just that sentence isn’t enough. I would have hoped that with all the explained equal issues on the forum it was enough. Snapping to certain lengths can be strong enough that it may interfere with snapping to correct existing geometry. Searching the forum on this issue hopefully helps you to understand.

1 Like

Thank you for this explanation–it answers the specific questions I had. Evidently this is exasperating for Sages and Learned ones, and Wo3Dan implies I should have “gotten it” by piecing together elements sprinkled throughout the thread. Maybe so, but I felt it was an unnecessary, if not demeaning comment. My bad for asking.

Sorry if you took it that way, not intended at all.

It’s all good, this medium of communication leaves a lot of room for misinterpretation. Everyone here is trying to help.