Login problems 3dwarehouse

login to the 3dwarehouse seems impossible. Trimble shows a page, but nowhere to login. Both safari and firefox.
Where these forums refuse my safari 13.1.2, where I cannot upgrade to keep needed software running.

A Google search for Safari 13.1.2 turns up a lot of complaints about various sites and applications that no longer seem to work with it. This isn’t unusual when Apple stops supporting a version and websites have to evolve to support newer versions of browsers.

In the Help files I found the following. It indicates Effective June 12th but doesn’t indicate which year. @colin might be able to shed light on that.

Have you tried logging in with Chrome? I believe that is the preferred browser.

1 Like

No. Chrome is google. Their privacy infringement makes chrome an absolute impossibility. My firefox is up to date. No succes there either.

I need high sierra to keep working. No option is possible to upgrade because of the prohibitive costs of hardware and software.

I guess you need to take that up with Apple.

From what I can find the last update to High Sierra was in November 2020. Apple seems to no longer supporting that version.

Apple… ever tried to take up something there? Their deaf ears are omnipresent. Whether they support it is irrelevant. It has to keep working, and it does.
Its mainly vectorworks here which is needed for some small business things.

Yep. But there’s nothing anyone here or at Trimble can do to make Apple change their mind and support your old OS for you.

Upgrading hardware and software is a cost of doing business.

Ah, the upgrade upgrade upgrade ■■■■. Hammered in by the shareholdercommunity. No need here, except i don’t understand why the login in 3dwarehouse does not work in firefox’s latest. Maybe the standard to refuse popups?

Maybe. You could try allowing them.

Other users aren’t having problems accessing the 3D Warehouse with Firefox. What’s different on your end?

A nice page, but without the login fields.

any chance you’re using a vpn ? or an adblocker ?

If you’ve got the trimble page with the white area on the right - that’s an adblocker/VPN/Firewall blocking things.
Turn those off and try then

Vpn yes. Always. Should make no difference.

Interesting website still refuse to accomodte security measures like vpn and adblockers. They should be on at all times.

A VPN isn’t inherently a security measure, but if your VPN provider is also stripping out other data and blocking certain things, then that will be causing the issue.
I’m using a VPN, as do many others and I don’t get an issue.

I think others have found it was related to google items in the login bar.
Contact your VPN provider if you need some config support.


it does.

From time to time, when I use my VPN, I go to google and get a weird white page asking me to prove I’m not a robot. because Google has seen too many connexions coming from this specific IP address.

unless I pick a server that is streaming-friendly, most streaming services will detect I’m using a VPN (in general, when I use one, It’s not for netflix, so I don’t care) and will refuse me access to their services. because they know it’s a VPN and therefore I might not be in a country / place where I’m supposed to access it (yes, even if I take a french server to hide my french butt)

Exactly, I’ve never had an issue with trimble / SU’s login while using a vpn, nor an adblock. Yet. and if someday I get the same issue, first step will be to check if turning them off grants me access.

if you go through a security check where they ask for your ID, like an airport, they will likely ask you to remove your hat, mask and sunglasses. or helmet. or whatever. because they want to be sure it’s you.
Trimble is a multi billion dollars company that deals with multi billion dollars clients that require security.
So yeah, even if you’re a good person, coming in good faith, they will ask you to remove your sunglasses, hat and vpn to check it’s actually you.

Still utterly silly, as VPN’s are ubiqutous nowadays. Trimble is not an airline, imho what they do is utterly ridiculous. Their security matters, mine is not interesting. Which sucks, as Trimble does with sketchup in the last few years. Blatently ignorant.

I do a lot of testing via VPN, I think it won’t be that. I have heard of people having problems with Firewall settings, but the majority of reports have been where an ad-blocker was being used. You can keep using those, but make sure it allows accounts.sketchup.com and id.trimble.com to work.


My nordvpn has a safe setting. Which cuts off trimble login it seems. Solved. Tx.