Lines missing when inserting into Layout

Hi, I have drawn a basic floor plan in SketchUp which I am then inserting into Layout. For some reason, when I change the model from Raster to either Vector or Hybrid, I am losing some lines from my window symbol. Also, when I save any changes to my SketchUp model, and then click on the refresh arrows, it’s not pulling those changes through. Any ideas why this is happening please? I have attached both files plus some screenshots so you can see what I mean.

Many thanks Abbi

** 3B Floor Plan copy.skp (5.7 MB)
3B Floor Plan.layout (5.6 MB)

You have two surfaces that occupy the same place*

*search the forum for ‘z-fighting’ to learn more about that.

Hi, thank you very much for your reply and for the video. I have tried doing what you did (I think I am doing right), and it’s still not showing those lines. I have also realised that it’s not showing the sink drainage either.

Have you read in the forum about ‘z-fighting’? Did you understand what it is?

Try to move each object in the Z axis to different heights.

Do not assign tags to raw geometry (edges, faces), but only to groups or components.

  • Linework is visible in Layout raster, but not vector.

there is one instance I know of where exactly this happens: If faces are on a different tag than the linework, and the face-tag is hidden.

As this is certainly not mainstream best practices for drawing things in sketchup it not happen very often. It seems you need to clean up your geometry so it all goes to untagged.