Dashed lines not showing in Layout

I have created a vector scene in Sketchup that shows only some dashed lines which represent a roofline above the floor plans. In Layout, I copy the raster viewport, paste in place onto the vector layer, and set the scene to the vector scene from SketchUp. What I get is the whole roof. Not floor plan, not just the few dashed rectangles that I want to see, but a whole top-down view. I can’t figure out what is going on. I have saved and updated everything. I even tried deleting the viewport and making it again. The SketchUp scene used to include a full floor plan in vector mode, but I turned off all layers except for the one dashed line layer thinking that maybe there was something weird with the other layers. Any suggestions?

I gave up on having a separate viewport just for vector lines. It seems like that is old advice that I was following. I figured out that the dashed lines have to be copied and pasted at or below the section cuts in Sketchup so they can be visible in the floor plans in Layout.