Line Tool issues and 'constrained on line intersect plane'?

hi there,
I am using Sketchup Free to draw a garden, currently in 2D, later I will add some 3D. I have watched several videos quite a while ago, but I am learning as I go along, which is not ideal, but I have tried to search this problem but don’t know what to call it.
I do not know what I have done, but when using the Line cursor, it now has an ‘n’ attached to it. I have lost the circular point when it finds an endpoint or midpoint. It is difficult to tell if it is snapping to the end etc.
At one point the end of my Line tool looked like it was a ‘grey shadow’ (I don’t know how else to describe it) but I must be toggling something on/off without fully understanding the consequences.
I do not know if my second problem is related, but I am trying to put dimensions on part of the drawing, and they seem to be hidden. It is only if I drag the lines out beyond my drawing that the lines appear. It is a section that I copied, pasted elsewhere, made changes and then tried to lay it back over the original - clearly a big mistake. I got the wording ‘constrained on line intersect plane’ which I have looked up a solution for, and it seems I need to redraw. Is there another way?

They probably just end up behind existing geometry (behind existing faces), so not hidden which actually means currently not visible in the model even when you orbit aroud your model. That can happen. You can rotate dimensions around the virtual line through the endpoints they measure.

Can you save your .skp file from the web (click on the menu then choose Download) to your computer, then upload it to the forum? It’s easier to advise you from seeing the model itself and not just a screenshot.

I really appreciate your help both of you.
Here is the file, saved as the 2021 version, I hope that’s ok.
I noticed that if I turned off the layers for the existing garden, and proposed drive, most of the measurements appear… and my cursor has changed back to the usual one. Although I would like to know how I got the ‘n’ line cursor…
So the main problem still remains to have the measurement ‘tails’ (?) to show when all the layers are turned on.
I also have no idea how to ‘fix’ the numbers on my scale, so they don’t move when i zoom in and out…
no problem if you don’t have time to answer that bit!
thanks in advance.

AKD site 020221.skp (3.6 MB)

In your model you have some text unattached to anything and at quite some distance to your terrain, the actual model:

"DRIVE (existing and
proposed shown)
*166.77M² *
*(assuming drive is 22m *
long from gate to bend)"

Either delete it and rewrite it closer to the model or do copy > paste the text into a new text block closer to the model (that’s what I did to keep the text available). Once I deleted the remote text entity, all the dimensions showed without any issues.

Wow - that’s amazing you found that. I was about to give up looking for it until I used the zoom extent function and found it miles out in space! thank you so very much. What a strange mistake I made. much appreciated!

If you delete the object that a piece of Text is attached to, SU can behave weirdly. That’s the most likely reason you caused the problem in the first place, and it’s an action you can easily make without noticing.