Licensed to SketchUp Pro 2017 user, Expired

reinstatement
installation
license
expired

#1

Hi.

For some reason my SketchUp says: Licensed to SketchUp Pro 2017 user, Expired. I’m pretty sure, when downloading I downloaded the Make 2017.

I have tried severel times tried uninstall og reinstall Make 2017, with a new download. Every time it says: Licensed to SketchUp Pro 2017 user, Expired.

When searching the forums I could not find any explanations how to solve this problem.

Downloaded Make 2017 from: https://www.sketchup.com/download/all

Kind regards
Kristian.


#2

Did you uninstall SU2017 Pro first and then clean the Registry before installing SketchUp 2017 Make?


#3

I removed SU2017 Pro or Make or what ever version it is :stuck_out_tongue: I then made a new installation from the link above.

Could u maybe try to explain more deeply what u mean? :slight_smile:


#4

I don’t know what you mean.

Use a registry cleaner such as CCleaner to clean up all traces of SketchUp from the registry before you attempt to reinstall.


#5

How to do that? Have installed CCleaner.

Have tried to run the cleaner and teh registry for problems, and fixed the once who came up.

I then tried to install SUMAKE2017, but it still says: Licensed to SketchUp Pro 2017 user, Expired


#6

This is what is says, when I open SUMAKE. Here I tried to install the 2016 version, still dosen’t work…

The file name is: SketchUpMake-en


#7

make sure Internet Explorer is up to date…

it can’t connect to the server, and needs to…

john


#8

Internet Explorer? Can the problem be, that I use Chrome?


#9

SU and other programs can only use IE before they are installed…

once installed SU will use it’s own Chromium for most things…

john


#10

Yes. SketchUp, on the PC, uses either a built-in Chromium toolset or Internet Explorer for its web-related functions, irrespective of what you have set as your default browser. If IE is not up to date or if you have succeeded in removing it completely it would create a problem like this.


#11

As far as I know IE is up to date. Just tried to downloade SUMAKE in IE, with the same result.


#12

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.