License activation not working

Hi,

I am experiencing license activation issues with an old SketchUP Pro? I’ve been using a SketchUP Pro 2016 license and tried to reactivate SketchUP after reinstalling Windows, as usual. However, I can’t even enter the license information at all.

I’m aware that the support period has ended, but I haven’t heard that it would render the software unusable. Is this an issue with the license server or is there another problem? Can someone please help?

Did you remove the license via the Help menu before you uninstalled or reinstalled Windows ?

1 Like

@colin can confirm, I think there was / is some problems with the 15/16 activation servers, meaning that even if you properly uninstalled the old machine, the new one might not get access to it.

He’ll tell us more about it when he sees this thread. maybe you have a more recent one available, or maybe there is a fix.

2 Likes

The existing problems with the license server prevent you from removing or adding a license. It seems to affect 2017 and earlier, 2018 works ok. Many things have been tried, but so far it’s not fixed.

2 Likes

Thanks @colin and @DanRathbun , @ateliernab for the quick reply.
Since my hard drive wend bad unexpectedly, I needed to reinstall everything from scratch. I did not have chance to disactivate the sketchup as well.
Is there any way to do it manually @colin ??

This utility lets you find files all over your PC, very quickly:

https://www.voidtools.com

If you search for SketchUp.lic, and find a file that is bigger than a few bytes in size, that may be a copy of your license file.

If the file you find is not already there, try copying the file to this location:

c:\ProgramData\SketchUp\SketchUp 2016\

then open SketchUp and see if it finds the license file.

If not, you may need to contact support to see if they can help.

https://help.sketchup.com/en/contact

1 Like

@colin Thank you very much,
Unfortunatly it was not applicable in my case.
As I re-installed OS on new SSD drive urgently due to the system and hardware failer, I did not have any chance to disactivate the SketchUP lisence in the old hardware setting.
It might be time to contact the supprot team, Thanks again.

The license is based on the MAC address of the computer. Running a system from an external SSD shouldn’t have changed the MAC address, and if you had found the license file it should have still worked.

Support can’t deactivate an individual entry, and if they did that wouldn’t let you add a new license because of the server issues. There may be something else they can do, so it is worth asking.

1 Like

Thanks @colin again and again.
The answer from the support was that I need to find a solution from this forum.
Unfortunatly, I removed old broken HD and replaced to new internal SSD to install OS on it. The license file was in the broken HD which had no chance to be disactivated, and I don’t have any way to take that license file any more.
Looks like it’s time to say goodbye to a good relationship of over 15 years with SketchUp.

This is not proper advice, as most here as mere users. We cannot fix anyone’s licensing issues.

SketchUp 2016 is near 8 years old and has been past support (EOL) for say 5 years.

Trimble only supports the previous 3 versions. To say it bluntly, … do not expect them to put any effort into repairing license servers for out of support versions.

Yes, they want to encourage users to upgrade to currently supported versions.

It seems you only other option is to find a SketchUp Make 2017 installer and run it without the Pro features.

Or use the browser based web app either Free or with a Go license.

1 Like