Length not applying - Newbie


#1

Hey ive a newcomer to sketchup. It have worked nice untill i encountered this problem with changing length’s. 50% Of the time i try to change a length by (Right clicking, entitiy info, then change length) It end up not applying. Absolutely nothing happens, so i gotta make extra lines just to get a line where i want it.

Another thing is, how do i edit a line that’s already made into f.eks a wall? Isn’t a big problem, but would be neat to know, if possible. :slight_smile:

And any good extensions for making homes? (Mostly modern, which is my biggest interest in architecture at the moment)

Would love some help, because im still quite new.

Kind regards.


#2

I’d use the move tool, point to the node at the end of the line you want to edit, and grab it (click release) then drag it to where you want. If your line is part of a solid object then you need to draw fold lines on the object on all faces where you want a bend to occur. if you don’t SU will draw fold lines for you, but it draws as many as it can rather than as few as it can. By drawing your own fold lines you guide sketchup as to what direction you want your line to extend: faces that cannot fold, will constrain the line.

Watch this video as i edit a rotated cube (rotated so no axis inferences interfered with the demo)
At first i dont draw any fold line, SU fold every face and my point is wagging around all over the place in space. Then i draw one fold line and see how that face folds and the line extends in the direction of the edge of the 2 remaining faces that cannot fold


#3

Thanks for the reply, it’ll be usefull :smiley:
But, do you know how to precisely change a line to a set length? I usualy just right click after making it and type in the length i desire, but sometimes this does not work. I read that i should not press anything else or it won’t work, but i don’t press anything else or drag my mouse out where it should not be. And it’s only certain lines.

Thanks for any help!


#4

Hi Peter,

     After the line has been drawn you will need to right click and open entity info . select the line and the size will be displayed. just type in what you want into the entity info box  and press enter and it will alter to that size. you don't need to put mm or inch only  symbols just figures.   You can also do it by grabbing the end point and moving it and you will know see the display box alter at the bottom ( not entity info as that would not have been selected)  . The size displayed is the extra dimension , not the overall length . so for example if you had a line 50" and you wanted it to be 75" you would move the end point any distance and then type 25 enter ,give a total of 75"
       If an edge is connected at both ends then this would be done with the above method . if one end is open then you can select the line and enter into entity info box and the line will alter to that size away from the fixed point, you can alter a line with the scale tool but this involves adding a small perpendicular edge  and then scaling , and then erasing unwanted edge after scaling. The scale tool by default displays a ratio and so to make something a specific size you need to include mm or " symbols after your figures, this tells the tool that you are want a size and not a ratio. 

hope that makes a little sense
Phil


#5

Thanks for the reply, but the problem isn’t solved yet. Tried to mark the line again, use symbols (mm/m/etc/none) Nothing works.
The weird thing is, it usualy works. I tend to have no problems the first 10 min i work on something then it fixes. If i have a problem with a line and restart it will allow me to make a line at the same spot, somehow.

No clue what this is.

But thanks for the reploy tho!

Peter

EDIT: It somehow works after i type in random lengths like 0 or 1 meter. Still no clue…


#6

Can you draw another line using the line tool, use the dimensions box to set that line to the length you want, then use the move tool to drag the node of the old line to the end of the new one