Leader text size is frozen


#1

I am modeling a house design in Sketchup Free (https://app.sketchup.com/app). I have successfully used leader text to label objects in the model. In the past, when I zoomed in or out, the leader text stayed in scale with the model. When I zoomed out, the text got smaller on the screen and the text fields did not overlap.

I have not used Sketchup for several months. Now when I use Sketchup, leader text stays at a fixed size on the screen. When I zoom out the model gets smaller but the leader text stays the same size and the leader text fields get gradually closer together, finally overlapping each other, resulting in a meaningless jumble of characters. (see attachment)

3D text does not have this problem, text size stays in scale with the model.


#2

What happens if you reset the browser screen scale to 100%?

Are you holding Ctrl when you scroll to zoom?

3D Text is entirely different from leader and screen text.

This is what I see when I zoom the browser window instead of zooming in SketchUp Free.


#3

DaveR:
100% screen size did it! Thanks very much.


#4

To be honest, Leader text is not really good for this kind of thing. I use Pro, so when I need to add leader text to an image, I use Layout. Since you’re using Free, I might recommend taking a 2D image and editing it in a PDF or image editor to add the text and leader lines.


#5

So far as I know, leader and screen text have never scaled with the model in any version. They are not geometry and are drawn directly to the screen at a fixed pixel size.

From @DaveR’s animation it would seem that in the Free (web) version they are drawn using a browser font and can therefore be scaled independently of the model, e.g. by resizing the browser window. In the desktop version you can set the font and size for screen text and another for leader text but they still are fixed on the screen and won’t scale with the model.

@dhannah’s point is valid. Screen and Leader text are relatively primitive annotation tools with many issues (as well as one known serious bug). For serious annotation you should turn to other tools such as Layout or an external image editor.


#6

Dimension text size can be set to scale with the model by specifying it size in model units.


#7

After the post from DaveR, I checked my display size at Windows/Settings/Display/Scale and Layout. It was 150%. Resetting that to 100% solved the overlapping problem, but that scale is too small for my vision.

I just looked into DaveR’s suggestion to zoom in Sketchup while holding CTRL. If I Zoom without CTRL, the model changes size and the leader text stays the same. If I Zoom with CTRL, the model stays the same size and the leader text (as well as all toolbars) change size. The larger the leader text is set and/or the farther I zoom out, the sooner text starts to overlap. So using CTRL + Zoom to set the leader text size large enough to read easily, but small enough that it does not over lap within the normal range of outward zooming out appears to be the solution.

Thanks to all.


#8

That wasn’t a suggestion. I only asked if you had done that because it’s one way to zoom the browser window text. Your screenshot indicates that the browser was zoomed to 120%. Normally you should zoom in the SketchUp window without holding Ctrl.