Text does not scale with drawing

How do I get the dimensions and text to scale with the drawing?

It’s not supposed to scale with the “drawing”. Go into Model Info and choose a different font size if you want.
Screenshot - 7_24_2023 , 3_26_43 PM

For Label and Screen Text select the text entities and adjust the size in Entity Info.

You’ll need to create them in the desktop version of SketchUp. The option is not available in SketchUp Web Free. Once created they behave as fixed size entities when zooming in and out, also when opening the model in the freeversion.
I may have misunderstood what you are after though.