Layout to PDF font issues

May I ask, do the lines with font issues contain TAB characters? The issue only appears for me when I insert multiple tabs into the text Layout text boxes or Label Text. For instance:

I opened a new Layout file. The file is not linked to a SKP file.
I inserted a text box containing the following:

  1. Some text here - no issues, though font appears larger than in Layout files
  2. Line 2 of text - no issues
  3. Line 3 of text - no issues
    a. More text - text explodes
    b. more still - text explodes
  4. Line 4 of text - no issues

Screen grabs of Layout and PDF files:

Layout:
image
PDF:
image

I’ve submitted the error to SU - perhaps they can replicate.

1 Like

JimD - great insight. I exported the file to PDF through the Win 10 print engine and the results were as they should be.

Also, I ran an identical test through Layout 2020 without the issues of 2021.1.1.

Indicates there may be a problem with the 2020.1.1 Layout Export function.

I’ve submitted a bug report to SU - and you’ve given me a little more to help that along - thanks!

My problems are Labels and Text, mainly numbers, they are randomly larger or smaller than ones in the Layout file.
Layout_file_export_PDF.pdf (295.5 KB)

1 Like

nanim3d: When I get some time today, I’ll attempt to replicate your issue.

I have found that if I export to PDF by using the Win 10 dialog, it works as expected - thanks to JimD for that suggestion.

It also works if I use an older version of Layout (2020, for instance).

I tried to print with Windows pdf and it works, but after so many years of using the export option I am just lazy to change the way I do get pdf out of Layout. :slight_smile:

Regarding the Bahnschrift font family: See these posts and the links they contain.

Thank you Dave for the links on threads. I read them.
I use Bahnschrift for at least three years now and never had any problems like this one, not on Windows, iOS, or any client complaints. I did open it on many computers and no problem until I upgrade it to the latest SU maintenance. If I print it using Windows pdf I get correct size fonts and all is good but if I export it gets scrambled. I will see with my students if they have any problems at home and I can check it on Friday on the school’s computers to see if it gets the same result.

I like it too and tried to replicate your problem without success. My Font dialog box shows quite many variants, did you use some other than the “plain” Bahnscrift? In your screenshots I imagine seeing a bit lighter font than the one I tried.
Edit: here is no difference between Light and Regular when exported. On screen the difference is visible.

I will definitely make a clean reinstall of SU and see if that helps.

I have a support ticket submitted with SU on this issue. The SU support rep was able to recreate the issue on his PC, but not on a MAC. It has been elevated to the SU software engineers for resolution.

Appreciate the input.

1 Like

Hi all,

This seems to be a regression in our PDF export caused when we updated the PDF library that we use to generate .pdf files. We’re looking into this right now.

Sorry for the inconvenience,
Adam

2 Likes

There is definitely some oddity in the Bahnschrift font too. The LayOut font dialog shows many varieties of the font. So does Word. Illustrator only shows Regular. When I make a font sample in Word and export that to PDF with Word’s built in exporter, all weights show as Regular, and condensed versions have their kerning run haywire.

Just encountered weird font problems exporting to PDF also from 2021.1 update


All text is standard Arial font 8pt…

A PDF created via the Print Driver for my PDF-Xchange Editor software prints correctly, no corruption showing…

1 Like

I am having the same problem here in our office on the latest update. Any ETA on when this will be fixed?

1 Like

I don’t think anybody is allowed to comment on specifics like future release dates. In a way I think we’re lucky that they already know about the issue, and have a good idea what’s causing it. so I would imagine that a fix will be part of the next release.

However, I would also argue that you shouldn’t have to wait for anything since you still have the option to run everything through the print dialog menu now. And as much as I can see how people feel that something is broken here. I would not consider the print to pdf option as a work-a-round or lower quality substitution. If anything it’s the more traditional way of generating pdf’s… and depending upon what pdf creator is being used it can also be an improvement.

Anyhow, I’m not trying to make changes to anyones favorite workflow, but instead trying to offer a level of acceptance to what’s a very common alternative approach.

This is one of the few times when built-in redundancy can save the day… or at least the task at hand.

1 Like

The challenge I have here is this is a critical feature I use every day, even every hour I am at work. We moved from a classic subscription model to a subscription model that I was not a fan of, and the last print issue I had with the classic license they said they would fix but did not fix till the next version of the software which essentially forced me into the subscription model just to fix a product I had already bought. I use this feature and have been burned by print issues before. An ETA is a small ask in my view for a critical feature at this point. I am paying more and feel like it has been a worse experience so far. I hope this does not continue to be the case.

1 Like

Same issue here. And I have urgent deadlines. Not sure what to do…reinstall 2020??
Any known workarounds/tricks to getting it working?

I’ve decided print out to PrimoPDF that I have installed rather than mess about saving as 2020 and exporting to PDF.

It’s not too onerous - at least in the print dialog box is easier to highlight the range and just type a single page number to print out single sheets…

1 Like

I guess try and print to PDF rather than export. Windows has to come in and save the day here?

1 Like

Doesnt work for me since the PDF export reduced the quality of my opaque image in a strange and ugly way.
This was using the Adobe PDF (professional) exporter/distiller, with the High Quality preset and the “version 8” compatibility (so it should support transparent raster images and colour).

So that workaround didnt work,