Layout shuts down when using my own made scrapbook


#1

Hi all, I have just spent two whole days drawing some standard construction details in sketchup and finished them off in layout , and saved all 12 details onto one scrapbook. Pretty proud of myself until I tried to drag a detail over to a blank Layout page for the first time. When I do, Layout shuts down pretty much straight away. I can drag them in and make multiples of them, but as soon as I hit ‘Esc’, or try to drag another detail over, it instantly shuts down.

I’ve tried every detail and some are ok, but most shut down Layout. All the default sketchup scrapbooks work.

What have I done wrong here? Is there something I could have done wrong with saving to my scrapbook?

Kerry


#2

House Raise Slab.layout (2.6 MB)

here is the scrapbook file


#3

Could be a memory issue on your machine. Have you tried on a different computer? It works on mine but given that your details are comprised of many SU model references, the links are broken when you shared the file.

My suggestion is as follows:

  1. convert your details from SU references to Scaled Drawings by exploding them so they remain live in the drawing and won’t break if/when the file changes or is moved.

  2. if problems still persist, try putting fewer details on a page, maybe 4 and see if that works. You can do multiple page scrapbooks with just a few on each. This also might make it easier to see the details when choosing as well.

Screenshot from when I open it with broken links and dimension strings:


#4

Hi eric-s, thank you for your reply.

I can’t see memory being an issue with 32gb of ram.
I have tried suggestion 2 first up, and singled out a detail in a scrapbook. The problem still exists. See attached. Does this work for you?

I really would prefer to try and fix the source of the problem if I can, and leave your first suggestion as a last resort. I know that will work, but I feel it would be a workaround for a common problem I might have with future scrapbook details I create. I would much prefer to work out what is actually happening for it not to be working, so I can prevent it from happening again.

Note I am new to SU, and these were my first scrapbook details.

Thanks again eric-s. I appreciate your help with this.
Trial.layout (220.2 KB)

Kerry


#5

@SketchHouse - Works perfectly for me. Have you tried re-installing SketchUp/LayOut? Would be nice if you could re-install just LayOut as I’m sure you have SU settings you’d rather not re-do.

Hopefully someone else from tech support is following this thread as it doesn’t appear to be a problem with your file. Wish I could offer more.


#6

You can not install LayOut or StyleBuilder separately.

If you reinstall SketchUp (by right-clicking on the downloaded installer file and then choose ‘Run as Administrator’) you would be prompted with an option to ‘Repair’.
This will keep the settings that you have imposed earlier.

Edit: I see you are on a Mac , now, the option ‘Run as Administrator’ is Windows only.
The correct way of installing SketchUp on a Mac is to double click on the downloaded ImageDisk and dragging it into the Programs folder…


#7

Hi guys, I run a windows PC. I tried repairing as instructed as an administrator, but the problem still exists. :frowning:


#8

OK. so i have done some trouble shooting, and have found that the problem is being caused by the hatching in Layout. I delete the hatching and the scrapbook details work with no problem.

With further investigation, I find that one area of hatching is fine. Two areas of hatching fails. I would have thought Layout would be able to handle more than one area of hatching??

Any thoughts?