Layout rendering slow

2017
layout
su2017

#1

since most recent upgrade, layout rendering ( of hybrid) extremely slow to the point of crashing…


#2

Graphics card driver current?


#3

its a mid 2015 macbook pro, with latest updates and running sierra…so yes graphics card is current as they are automatically upgraded


#4

If it’s SBBOD, you can kill it and get a spindump that might give clues:

  1. cmd-option-esc
  2. Select LayOut and end task. A spindump should be generated.
  3. Copy and paste and PM to me, or look at it yourself and see where it appears to hang.

One thing to be sure of: on MacBook Pro’s, be sure Sys Prefs->Energy is using your “better” graphics card instead. Your profile lists Intel Iris Pro 1536 MB but don’t you also have a NVIDIA GeForce? If you’re not plugged in, or have your settings funny, it may choose Intel over the much better NVIDIA card. I choose to always use NVIDIA at the expense of battery:


#5

i don’t seem to have the option “automatic Graphics switching”….


#6

I tried rendering on iMac with same slow rendering and crash …this is report Date/Time: 2017-03-01 09:06:12 +1000
OS Version: Mac OS X 10.12 (Build 16A323)
Architecture: x86_64
Report Version: 25

Data Source: Stackshots

Command: LayOut
Path: /Applications/SketchUp 2017/LayOut.app/Contents/MacOS/LayOut
Version: 17.2 (17.2.2554)
Parent: launchd [1]
PID: 2134

Event: hang
Duration: 3.00s (process was unresponsive for 55 seconds before sampling)
Steps: 30 (100ms sampling interval)

Hardware model: iMac12,2
Active cpus: 4

Fan speed: 1157 rpm


#7

So you must have the 2.2 GHz - 256 GB version listed here? https://support.apple.com/kb/SP719?viewlocale=en_US&locale=en_US That’s a rare one with only Intel. So can you create a spin dump?


#8

Morning All,

I have the same issue - LayOut 2016 used to be OK - a little slower than for instance AutoCAD - but really OK. LayOut 2017, however is incredibly slow. When I resize viewport into the skp model it takes a really looooong time to process. This is so bad that I will be missing a deadline today. I please need assistance / advice.

My skp model is 65Mb large (already purged) and the Layout file is 35Mb large. Single storey house built in detail.

My power settings are on High Performance.

I’ve tried driving LayOut purely with the NVidia drivers through the superior GPU, and also the “Auto-select: Integrated” option. Not making a difference.

My system as follow:
OS: Windows 10 64-bit
CPU: Intel Core i7-6700HQ (2.6GHz)
RAM: 16Gb
Graphics: NVidia GeForce GTX 980M (with latest drivers)
HDD: Solid state