LayOut Problems with <DateCreated> AutoText

I have been trying to use the AutoText variable “” in a LayOut document and cannot get it to show anything but “April 27, 2012” regardless of when the LayOut file was created or when the SketchUp model file was created. It is my understanding that this variable behaves as follows: “Date Created: Inserts the date file was first created. This value only changes if you select File > Save As and save the file under a new name.” However, I have had no success with old files, new files, and files saved under new names. Any guidance?

Can you upload an example?

Here is a screen shot of the AutoText option page with highlighted. The bold text outside the box are some test AutoText text items that, I believe, show how various options work fine except for the option. If I try to edit the option, I can only change the actual “” part of the text. It certainly does seem to be behaving like the Help descriptions.

BTW, I just noticed in my reply that every where where I used the DateCreated phrase enclosed in <>, it did not show. Sorry. I hope you can read between the lines.

Here is a screen shot of the AutoText option page with “DateCreated” highlighted. The bold text outside the box are some test AutoText text items that, I believe, show how various options work fine except for the “DateCreated” option. If I try to edit the “DateCreated” option, I can only change the actual “DateCreated” part of the text. It certainly does seem to be behaving like the Help descriptions.

Done, after a fashion.

1 Like

Any thoughts yet?

You need to use the Preformatted text


in order to show up properly in this forum.

I do not know why your DateCreated shows April 27 2014, I was on a site, all day:

:grinning:

Most off these problems can be solved by repairing your installation.
Rightclick on the downloaded installer file and choose ‘Run as Admin’
When prompted, choose ‘Repair’

This might solve things.

I just did the “Repair” procedure. The DateCreated still shows as “April 27, 2012.” Ugh!

Is it really possible that I am the only one for which this is happening? If you do a DateCreated AutoText in one of your files, does it work correctly? On this laptop, I am not even sure that I have a file going back that far!

Kent

PS: Your job site photo seems to have a wire coming out and looping right back in and also some missing tile work - similarly: Ugh!

yeah, sorry for that, most of the time was taken pics during building, they wouldn’t allow me when finished (It was a brewery)

Anyhow, I just wanted to check a file around that date and inserted the Autotag:

(Pretty close, huh)

Are you using an old template?

I will try a brand new file from a different template. Regardless, the “File Save As” option to establish a new date certainly didn’t work.

I tried some experiments, and I believe that I have narrowed the problem down to a specific group of LayOut files - the 2016 Templates from the SketchUpFor Architecture (Nick and Matt). And I believe the option in the LayOut instructions about DateCreated won’t change unless you do a “FileSaveAs” is not working or is not correct - I’ve tried both several times. I can elaborate if you wish, but briefly a LayOut file created today from one of these templates will show a DateCreated of April 27, 2012 even though the Windows file properties show is creation as today. I have attached one of these files if you want to try it on your end.A2_Floor plansTEST.layout (312.1 KB)

Ah, there is something with your file. The last extension is .zip, so the file reads: A2_FloorplansTEST.layout.zip
A LayOut file is actually just a zipped file and I think LayOut is capable of opening it, but something is missing along the way.
Your system might be set to open them with LayOut, thus causing havoc.

You need to set ‘Show Extensions’ in the Windows Explorer in order to see the full name of the file.
I unpacked the sent file (being on Mac, only double clicking, on Windows: rightclick and choose unzip)
Then open in LayOut and choose [menu]File->Save as Template. It will be in the My Templates section.
Now, if opening a new, the DateCreated displays correct.
do it now, test tomorrow…

I think the original set was zipped for download purposes. @Matt


And yes, the red cake indicates it is my birthday…

@MikeWayzovski Happy birthday, and thanks for tagging me!

@ksnelson1 I downloaded your file, and I see what you’re saying. Try going to File > Save as Template, then create a new file from that template. The date created autotext will show today’s date.

(EDIT: I just realized @MikeWayzovski suggested the same solution, lol)

1 Like

Thanks! My mystery is solved.

Thanks Mike and Matt! My mystery is solved.

You did some deep digging for that solution, on your birthday no less. Nice one.

1 Like