Layout not saving - Error No 10

Every time I try to save a LO file it crashes (bugsplats)
Even before I try saving the LO file I get the message “Something just happened to this document and it cannot be saved. The error code is 10.
Please revert to your last saved version.”
It will update changes to the current SU file but will not relink to another SU file.
Has anyone got a solution to this?

Do you have a server or some other location where the reference files reside? Maybe there is a conflict between the server and temp location on the machine. Try looking for suspect files in the Document settings. Perhaps relinking them to files can make a difference.

Thanks for your quick response.

No I don’t have a server. I have relinked all the files in Document settings and LO will still not update.

Can you go back to the reverted state by ‘undoing’?
If so, go all the way back and save after each ‘redo’.
The one action that causes the error should be the culprit.

I am starting to think that it goes back to a LO title block template I have been using
which had some hidden scenes from an earlier SU model which has only shown up with

the new SU release, as other files using the same template seem to be doing the same thing.

Having said that I have removed the new version and reverted to the earlier version of SU2020

and everything works as it did, so hopefully if I fix the template before going back to SU 2020.1

al should be well.( fingers crossed).

Thank you again for your comments, which have led me to this conclusion.

Hi, I have the same problem and also want to revert to SU 2020.0 but can’t find the file to download. Please help.

Recently had someone with this problem. Was using onedrive to sync and had turned on autosave.
Saving to a location on the C:drive that was not infected by onedrive solved his problem

We have a few people that we are working directly with, to track down the error 10 issue. Mike, I’ll get Trent to drop by, to see if what you said may be important.

Meanwhile, this link will work for a few days. It’s the Windows 2020.0.1 installer:

he was using the latest windows version, I checked. Had a 6 page document not that big (16MB).
Adding pages (up to 13 or so) then the autosave kicked in, the message popped up and he had to revert to the 6 page which he had started with. First tried moving the file to the desktop, but realised that Onedrive is merely creating a shortcut. I figured that there might be some metadata attached on the file itself, so we tried to copy all pages in a new doc and saved it to the C:Drive to be sure it wasn’t in any of the folder’s that are controlled by Onedrive.
Opening that file and adding the pages again (Autosave was turned of, Backup not) and saving manually did work, then.

1 Like

:disappointed_relieved: It crashes all the time that I’m saving the file. If i didn’t refresh the SketchUp file it works. But i need to refresh.
I’m using SU2020.1

Did u find a solution? Thanks!

No, sorry I’m not aware of any solution yet. I have gone back to SU 2020 in the meantime. It’s a bit of a nuisance
because some of the new features were a big improvement. I understand SketchUp are working on it, but it’s

taking a long time.

Hi all, we appreciate you all providing your input and files to use in this investigation. It turns out that the issue is related to the users UTC + timezone (for example UTC + 01:00) and the timestamp associated with the last render of an inserted SketchUp file.

If the SketchUp file has not been rendered since it was last edited, LayOut will crash once the file is saved. We are working on this fix.

Enabling Auto render in the SketchUp Model panel will prevent this from happening.

Sorry for the inconvenience this may have caused.

Trent

2 Likes

Mmmmm, not too sure about that, I always run LO with auto render switched on and update the SU model in LO
every time I save it if it doesn’t auto render quickly. Would like to have a bit more confidence that the issue is really

fixed before going back to SU 2020.1, I wasted a lot of time on it.

Hi, I have the same problem with error 10 in Windows. I had to go back to SketchUp 2020-0-1.
I use OneDrive, but the problem occurs even if I save it locally c:/ I’m waiting for a solution. Thank you.
Sorry but my English is very bad :slight_smile:

Did you try what Trent suggested, and turn on auto render for the SketchUp model? That should work around the crashing problem.

Thanks for your answer. I’ve activated Automatic —> Raster. But the program doesn’t crash, it has problems with saving, error 10. Unfortunately now I’m doing an important job and I didn’t install the latest version. Maybe I can install on a 3rd PC and try again. Best regards

Im on Onedrive and having the same problem, everytime I try and save it stuffs up,

What did you do to fix this?

Crash Report #4176

Sorry LayOut crashed!

We have an issue related to your time UTC + timezone and the timestamp associated with the SketchUp file. When your LayOut file is saved there is a mismatch in the two and will cause this crash.

If your original LayOut file is no longer available copy, rename and use the backup file.

A work around for this is to check Auto Render on the SketchUp Model panel and select on each of your pages before saving your file.

Sorry for the inconvenience

Are you trying to save to Onedrive or locally?

Trying to save to Onedrive, I also tried saving locally and didn’t work either.? I using my laptop now with the same file and it saves fine, its something about UTC timezone out of wack… this is really becoming a pain in the …

There is now a 2020.1.1 installer, the downloads page has been updated:

https://www.sketchup.com/download/all

In what might be the shortest release notes ever, here’s what is new:

  • This is a Windows only update to fix a frequent crash that occurred with users on the positive side of the UTC time standard (for example UTC+01:00). This crash would occur due to an error encountered when converting some local times to UTC when reloading a SketchUp file then saving.
2 Likes