Error code 10

Sometimes I can’t save the layoutfile and get the error code 10.
This is new since the update to version 20.1.229.
Is there already a solution or an
officially patch?

We are investigating this issue currently but are having difficulties reproducing it locally. Error code 10 indicates that a save is already in progress when another save operation has started.

I’m sorry for the inconvenience,
Adam

Same problem here.

Hi there,

after installing 2020.1 I am really proud of the new selection possibilities in Layout. Easy. Superb :-))

I was working on an Layout 2020 and SU 2020 file. Then I updated to 2020.1. Modeled along 3d. Drawing Details in Layout.
BUG SPLAT in Layout 2020.1

The LAYOUT file I was working on disappeared. I did not find it in my project folder. Only the “Datensicherung von…” file was there
After reopening LAYOUT I tried to recover the file in the open dialog. This message accures:
Anmerkung 2020-05-11 233914

After hiting OK. Nothing happened. The recovery failed…
It was not so bad for me because It was right at the start of working on the file. Loosing the file was in this case not huge damage for me…only 1 h of work

Then I took the “Datensicherung von … .layout”-file and opened it.
The same error occurs when working on this file after I guess 5 minutes…

Still loving sketchup

Ah I forgot: The Error code 10 Alert was there too…

I have the same problem “Error code 10 " and a very similar behavior like SPB discribed … additionally I made the observation that the " StartUp-Window” is completely blank.

Here it is:
New File:
This came up:
Fehlercode10
When I wanted to save with another filename:
Fehlercode 10 2
After clicking Nein/No this came up again:
Fehlercode 10 3
Then I decidet to open up a second fresh Layout File to copy the sheets from error10-file into it, by strA, strC—>strV That worked fine. After trying to save this File. Bugsplat:
Bugsplat
I sent the ErrorReport.
then opening Layout and selected the recovery-File:
This came up again:
recoveryfileAlert

Again some data lost…What can I do to avoid data loss…

Is it possible to switch back to 2020.0 ?

Still loving Layout…

Hey SPB,

interessant was Du da machst. Bist Du im Maschinenbau tätig?

Ich bin Tragwerksplaner / Statiker und leider eine der wenigen in Deutschland, der mit Sketchup arbeitet. Wäre interessant sich auszutauschen.

B. Schuh.

Bei Interesse:
info@ingschuh.de

As stated before, I have the same problem.
Is this problem known with other language versions too? Or might this be a “German” problem?

I experience also that I cannot run “Repair” from the installer package as it will prompt that it cannot finrd the necessary “MSI” file.

Greetings from Berlin

Exact same issue here!

Hi Trent

Major issues with the layout drawings crashing with an error 10 and then worsted of all losing the file totally.

I am working in pro 20.1

HELP

Later:

It seems to be the 20.1 layout can’t recognise the updated 20.1 Sketchup when Sketchup drawings are updated from version 20

I have to create another set of layout drawings, insert Sketchup drawing and that works. SO FAR

NO it crashed again

Layout would not save with error 10.

Purged the drawings to get another message “Cannot access a disposed object. Objects name DocChildForm” I am investigating atm

I’ve spent most of today on this. My client is very understanding so far

Can I revert to earlier 20.0 version so I can continue working

Ronson
RDO design
rdodesign@tpg.com.au

WE went back to Layout 19, saving as skp2019 - files from SU2020 until there is a solution…Our clients are more nervous.

SOLVED so far. With the help of Trent from Sketchup

From Trent:
We have discovered that the issue is related to your time UTC + timezone and the timestamp associated with the SketchUp file. When your LayOut file is saved there is a mismatch in the two which will cause this crash.
Setting the Auto render in the SketchUp Model panel will prevent this from happening.
In reply:
Tried today with the model auto render ticked and it crashed but with auto render unticked it worked perfectly .
So playing around with the Model auto render in Layout worked for me.

I have been experiencing the same issues with error “code 10”, “DocChildForm” and others. I am currently using version 20.1.229 64-bit.

Turning off the Auto render has also worked for me solving the Code 10 issue immediately.

Try build 235

1 Like