Layout not responding when inserting view ports

Good afternoon - when i insert a Skp view port into Layout 2024 and edit anything that takes energy LO goes into " not responding " mode
we have been doing these same steps on earlier versions with little issues.
where do i start for trouble shooting

Start by sharing the SketchUp file as well as the LayOut file so we can see what you are working with and give you some ideas to fix the issue.

Are you still using SketchUp 2022.

Shop Draw 23.12.14 Floor System Details.skp (2.6 MB)
23.12.14 FP PRELIMINARY.layout (15.3 MB)

let me know if you can get these ok

we are using 2024

Sorry. Didn’t think you would respond so quickly. Just getting on the road for home. Will look when I get there.

Please update your forum profile.

I got the two files you’ve shared. The .skp file that you shared does not appear to be the same as any of the seven .skp file references. That said, in that SketchUp file I see you have Profile edges on in the style. Turning them off would help create a faster style. I also note a load of incorrect tag usage although that shouldn’t have anything to do with update speed.
Screenshot - 6_14_2024 , 5_56_26 PM

I opened one of the .skp references in the LayOut file and see you have things strugn out over better than 1200 feet along the red axis.


This can create graphic issues and because of the details and all the geometry that is still present in the close up up scenes, you’re making LayOut expend a lot of “energy” when it needs to render the viewports. For example, you have this scene:

Even thoough there’s only a little bit of stuff visible in this scene, everything that is shown in the previous screenshot is still present so LayOut has to use take the time to consider every edge in the model to determine if it is visible and needs to be rendered or not. If you were using tags effectively to control the visibility of the objects in the model you could avoid stringing parts of it out across the county and that would also let you create scenes that show only the objects of interest. By turning off the unneeded tags LayOut won’t spend time on geometry you don’t care about because it doesn’t show anyway.

This file, the Side Wing SketchUp model has the same issue with incorrect tag usage as the file you shared separately.
Screenshot - 6_14_2024 , 6_09_47 PM
It also has a lot of unused content in it.
Screenshot - 6_14_2024 , 6_10_01 PM
Cleaning up this file reduced its size by 37%. I would expect the others could probably benefit from the same sort of cleanup.

Another one. Same sort of geometry spread out across the county. Similar incorrect tag usage thing. Purging unused eliminated this:
Screenshot - 6_14_2024 , 6_24_28 PM
File size reduced by nearly 60%.

None of these SketchUp models are especially huge but they are much larger than they need to be.

In a nutshell, cleaning up your SketchUp references will go a long way to helping with performance. Then also using tags to limit the visibility of objects in each scene and keep the objects close to the origin will help to speed up rendering in LayOut and reduce the number of times you see the Not Responding message. BTW, Not Responding only means that LayOut is busy doing the last thing it was told to do.

In LayOut I see an issue with some of the viewports. You’ve modified the Camera properties, probably by panning or zooming in the viewport.

This can be problematic, especially if you’ve added dimensions and labels to a viewport and it gets reset. Example:

As you have the viewport:


After reset:

I wouldsuggest that there’s absolutely no need to modify the camera properties. For the elevation and plan view scenes, set a suitable scale and if needed, drag the edges of the viewport but don’t click into the viewport and adjust the camera. Also modifying the camera in LayOut overrides the Camera properties in the scene so even if you pick a different scene, the viewport won’t change the camera position.

I hope that helps.

1 Like

Thanks Dave i appreciate the input.

so i have striped down the Layout file to only the last pages and am inserting the skp file i sent you and. to update the reference takes more then 30 min , which is hardly functional.

the view port is only showing the portion of the project that is needed in the view.

the memory usage is at about 65% with a16gb of ram

i feel there is something that is over loading it that i haven’t been able to point to.

is there a way we can do a call and drill down through option faster ?

Did you simplify the model as I suggested? I’m not seeing such long delays with updates to the viewports on my machine. Do you really need ALL 677 of those detailed 3-8 Screw components in your model of the building?


Each of those screws adds nearly ten thousand entities to your model. You’re making LayOut spend time rendering those screws. The same question go for the "THD37400H screws.

Over fifty thousand entities in one screw. Again, you’re making LayOut figure out if it needs to render those entities and that tages time.

And again, the Simpson HTT5s in the model. Again they are overly detailed for what they do in this model.

I would suggest that you simplify those objects in this model or totally remove them. Make a separate model showing those as typical details but without the rest of the building. Doing that would definitely speed up the process of working in LayOut. It would also speed up your process when you are modeling the structure.

Another thing you might consider is editing the style(s) in SU and turn off Profiles. They also add to rendering time.

you mentioned not seeing delays - is that using the file as i sent or stripping it down ?

the first number of pages with the tags not used to capacity is a good point. i hadn’t realized that is how it was done. that should be easy to correct. but it doesn’t appear to be the real bottle neck issue though it will help.

how does computer capacity compare ? or effect the render speed.

i tried to turn off the profile edges in sketchup and that seems to degrade the view quality considerable. is there another way to keep quality image with and turning off edge profiles?

in LO it defaults to using the render mode “raster” which seems a low grade view. if i change that to Vector the quality is much better and makes a readable view. but it seems this also take a lot of energy.

i could delete may of the components and just do a few key views but the would defeat the ability to count parts easily. and to cut sections at any place without redrawing portions.

i feel there is something significant and perhaps obvious that i’m missing

  1. are we attempting to use SKP and LO way beyond there capabilities
  2. computer way under sized

Using the file you sent. I said I’m not seeing the delays you report (30 minutes) but it is still sluggish.

The hardware affects render speed. The CPU speed, GPU speed, and GPU memory all play into it.

Was that using Raster rendering? Keep in mind that LayOut, by default, reduces display quality while you are working on the file to help keep things working faster. Output quality will be better. Having profile edges turned on makes the GPU work harder because it has to look at every edge and decide whether or not it should be shown as a normal, non-profile edge or a thicker profile edge.

Yes. That is to be expected because you are again making LayOut work harder to render all of the endges in the model.

You can substitue very simplified components for those detailed ones and still get effective counts.

I don’t think so. I do think you are not creating efficient models, though. As is typical with newer users, you don’t seem to have a good, clean workflow and you are investing too much in parts of the model that don’t add much information to the overall story.

I don’t know. Not enough information. CPU speed, GPU RAM, etc. are all important but before you even start looking at other hardware I would suggest getting a handle on making efficient models. Even with a “better” computer, efficient modeling will go a long way to improving the way things work and in reducing the amount of time you invest in projects.

ok so Training would likely be the best place to start.
where can we get good training.

we have done quite a number of the courses that are available on Linkedin now , that were on the lynda.com site.

is there a better place ? or process specific trainer that we could connect with ?

Have you done the tutorials at learn.sketchup.com?