Layout labels losing their place

Hi, I’m sorry to bother you with this problem. It probably has to do with me being a total newbie to Layout.

Since I have a Swedish version of the program, I’m probably not using the right terms, but I’ll try to describe my problem.

A few weeks ago I started using LO and imported my SU drawing. After that I placed text labels with arrows from different objects. When I was satisfied, I began building my next blueprint on page 2, and has been working on that one for a while. Today when I was going back to page 1 I was devastated when I noticed that more than half of my arrows had lost their position - they where drawn out and out of place.

I hope this screenshot shows what I mean:

  1. What do you think has happened?
  2. Is there any way to fix it or do I have to move all the faulty ones manually?
  3. How do I prevent this from happening again?
  4. Why is it that only some of the labels have lost their postition, while some are intact?

Please, if any one here could give som guidance I’d be very thankful.

Thanx, Jimmy

It would help if you share the LayOut file. The most common reason I’ve seen for this is when the model appears to have moved within the viewport either because the viewport is linked to Last saved SketchUp view or the camera position was changed inside the viewport to pull it away from a scene (or both).

Thanks Dave, for answering. Here’s a OneDrive-link to the file:
https://1drv.ms/u/s!AsvhUzm1JtAj1ydxNndNv3wUuDO8?e=nfTK0r

Please let me know if you find what I’ve been doing wrong.

//Jimmy

Now I tried re-linking the scene to a newer SU-file, and all the arrows lost their placement again. :frowning:

I see what the problem is. You’ve basically moved the “camera” within the viewport. Double clicked on the viewport and panned. That creates issues if you need to go back to to the SketchUp model to make updates. Here I’ve reset the Camera settings for the viewport and dragged the edge of the viewport to show that part of the model again. You can see that labels which have leaders anchored to the model are still anchored to the model. The other labels weren’t anchored to points on the model so they stay where they are.

Instead of panning the camera in the viewport, it would be better to simply drag the edges of the viewport to show what it is you want to show.

Here is your set up of the viewport on the page. Notice the dark gray background in the Camera section of the SketchUp Model panel. This indicates you’ve made changes away from the scene camera settings.

On the right I have made a copy of the viewport, reset the camera setttings and just dragged the viewport edges to show exactly the same thing you did but without creating the problem when updates are made.

Exactly because you had broken the link before by panning the camera in LO.

If you don’t do that, you won’t have the problem. There even a setting in LayOut’s preferences to disable editing the camera position in the viewport. Leave the box unticked.

Screenshot - 1_21_2021 , 12_25_44 PM

By the way, I would suggest you use layers in LayOut for various entity types. Put labels and dimensions on their own layers higher in the layer list than the viewport(s) so you can lock layers of make them invisible to clear out clutter as you are working.

Thank you so much for taking you time! I’ll look into your screenshots and try to figure out when changed the viewport camera and why.

About the labels… yes I’ve noticed that some of them did not change. The problem is that I thougth I anchored all of them to the model. As far as I know, I did it the same way with all of them. Do you know if I have to attach them to a line?

I realized I should have put the labels in a layer, but too late. Can I do it at this time?

Would you say that have to start over with the drawing, or can I fix it with a new Viewport?

They need to be attached to something in the model. An easy way to figure out if the label is anchored to the model is double click on the label text and see if you get an option to shoose an Auto Text entry. In the following screen shots, T2-1 is anchored to the model while P2-28 is not.
Screenshot - 1_21_2021 , 12_39_54 PM

Screenshot - 1_21_2021 , 12_40_05 PM

Edges and endpoints are sometimes easier to get labels anchored to but if there’s a face, you should be able to anchor to that, too.

Yes. You can put the labels on a layer of their own. Create a new layer for them then select them and right click and choose Move to layer. Or maybe easier, select all the labels, cut them to the clipboard with Ctrl+X and then after making sure your Labels layer is active, right click somewhere and choose Paste to Current Layer.

You can fix the viewport although it might be easiest to redo the labels. To fix the viewport I would suggest dragging the bottom edge down a ways. Then click the Reset button under Camera in the SketchUp model panel. Drag the edges of the viewport to reframe the model as you want to show it and move it back into position.

Perfect! Thanks a bunch! :blush:

1 Like

Good luck!

Hi Dave, I’ve messed up again. Care to have a look at it again?

This when I opened LO today the viewport had changed on the first two pages. Now it seems like the models have been upscaled!
Yesterday I was working i SU and making a new scene, that I later imported to LO, on page 3.
Could that have messed up the viewports on page 1 and 2? I don’t get it.

Here’s the file, if you care to take a look.
https://1drv.ms/u/s!AsvhUzm1JtAj1zrj0CKmgKxPM1po?e=sWzZvF

Brgds, Jimmy

Hi Jimmy. I’m about to start an online SketchUp instruction session with someone but I’ll look as soon as I’ve finished.

By what method did you import the new scene to the 3rd page? There are two references to what should be the same .skp file and you should only have one reference. That typically causes problems, especially when you need to make changes.

In SU, I’ve been drawing my three different models next to eachother. And then made scenes with different styles to part them.

I’ve noticed that my scenes have had a tendency to change slightly sometimes. And sometimes I’ve had problems making my changes stick. Maybe it is a bug or maybe it’s me.

Anyway, the last SU model I made is really a .PSD-import. I did it to be able to get the correct scale ratio.

When I got to LO, I put a viewport on page 3 and pointers it to the .PSD-model in SU and made sure it was in the correct scale.

I’ve also noted that I have two SU-files as reference. I think I saved an old version in a new name a while ago, to be able to go back if something messed up. Do you think that might be a problem?

I’m sorry but I think it’s you. I see some issues in your SketchUp model such as incorrect tag (layer) use. All edges and faces should be untagged. I corrected that and got the following. It means there was a lot of geometry that had been tagged. Only objects (groups and components) should get tags.
Screenshot - 1_27_2021 , 6_56_15 AM

It’s also a good idea to purge unused stuff from your models once in awhile.
Screenshot - 1_27_2021 , 6_56_53 AM

As for the slight changes you refer to, what sort of changes are you seeing?

In LO you have moved the camera for the viewport on page 2 which can cause you issues when you are making changes to the SketchUp file and updating the reference in LayOut. As I mentioned before, it’s better to leave the camera alone in LO and just move the edges of the viewport if needed. You can see the model shift slightly when I reset the camera change you made in LayOut.

Some label leaders are anchored to points in the model and those leaders update when the model shifts on the page. The ones that aren’t anchored stay. Most of the labels for this viewport are anchored to the model. Some of them on Page 1 are anchored but many aren’t.

That’s a decent way to work although I might consider using a viewport of the actual model as a temporary reference on page 3 and insert the image from PSD directly into LayOut. It can be sized to match the model and then the model viewport deleted. (Or left on a layer that you normally hide for that page. That would make it easier to use it later if you need to.

The main problem would be file bloat. The LayOut file ends up being much larger than it needs to be because there are multiple copies of the SketchUp file contained in it. The other problem would be if some viewports are referencing one of those files and the other viewports are referencing the other file things won’t match up.

As I look at your SketchUp model more I see that you could be working in a much more efficient manner if you would use the same model throughout instead of stringing out copies of it. With appropriate use of tags to control the visibility of the various objects in the model you should be able to show everything you want in each viewport with no problem. In fact, if you were using tags correctly and since you are using SU/LO2021, you could manage to use a single scene for both viewports on pages 1 and 2. Not only would this make model management easier, it would reduce file size even more (purging unused stuff reduced the file size by over 16%).

Good evening Dave!

I have to ask, are you employed by Trimble or is this a hobby of yours? Anyway I’m very thankful for you trying to help me out!

I figured that I’ve made a lot of beginners fails. :-/
I’ll go through your notes one by one, but the main thing I can’t understand is how the viewport seems to be showing a bigger model now than before.
Last week, I exported a PDF of page 1 and 2 from LO. Page 2 looked like this:

Now, the model hardly fits in the window or even in the blueprint frame. How is that even possible, when the model i SU says that the scale/yardstick reads 5 meters, and when I measure it in LO it says the same. And so it did before it grew!
I’ve tried moving the viewport to fit the non-anchored label leaders, but I just can’t get it right.
Can you figure that out? LO still says that it is in scale 1:100, which is what I want.

Hi Jimmy,

No. I’m not employed by Trimble. I’m probably just a glutton for punishment. :crazy_face:

The scale should be the same but the edges of the viewport can be dragged to control how much of the model space is displayed.

This is what I see in the latest version you shared. It seems to fit OK on the page at 1:100.

Although tedious to do, it might be easier to move the labels or at least move the arrowheads on the leaders.

Hehehe, okay. :laughing:

Yeah, that I know.

Yes, it fits ok, but can you see that it is bigger than the one I exported earlier? In that one I had more margin in all directions.

Yup, you’re probably right. I just tried to move the viewport to see if it matched the labels that had not moved, and it didn’t. That’s another reason that I think the model have grown larger. I just don’t see how and why. :pensive:

The only way I can think that the model might have gotten larger is if you scaled the geometry in SketchUp.

Here’s something you might consider doing. Make components in your Sketchup model to which you can anchor labels. Make the component definitions match what the labels will be. Here I did that with some small circles that are admittedly hard to see in the screen shot. The label text is the name of the component in each case.

I gave those objects a tag in SketchUp and once the labels were placed, I turned that tag’s visibility off in the SketchUp Model panel.

The labels remain attached so when the viewport gets moved (or if it scale was changed) the leaders go along for the ride.