Layout label data incorrect


#1

Hi,

I have a small problem and hope you can help me.
I’f made a dynamic component (with components inside) in Sketchup where I can insert the dimentions, color and so on.
I send it to Layout and retrieve the information with the ‘labels’ function.

And now the strange part…
All the sizes are show correct exept the size of one component…
Layout problem.pdf (99.4 KB)

I have checked, and everything is set to ‘cm’ and not ‘Inch’ so that’s correct

Hope some of you guys have a great idea how to fix this.


#2

Maybe the solution is that:

image


#3

better upload the .layout file instead of the .pdf


#4

Hi guys,

@Eduardo
Thanks for the suggestion, I checked it but sadly it’s not the solution

@MikeWayzovski
Great Idea, here are the Layout en Sketchup File.

Layout File

Sketchup file


#5

Check the Component Options dialog box, the options to change are in “mm” and not in “cm”


#6

right click model update in layout fixes it, don’t know what caused it


#7

Thanks for your reply,

In the component attributes you can choice between Decimal number/text/inch or cm and not mm.
Therefor I choice there cm.
My colleague works in mm, so I choice for mm in the component options
That’s working fine for all the components except for ‘component 1’ dimentions
Never the less I did try your suggestion and still the same wrong data in Layout


#8

Looks like it is properly reporting to me @ 140mm. (as measured in SU)
Unless you wanted cm, in which case you must change attributes an apply them.
Maybe I just don’t understand the question?

Charlie


#9

@Charlie_v

Oke… now I’m flabbergasted.
So if it works correctly on you system, than where can the source of my problem be?
I’f checked and my programs are up to date.
I also made a report with ‘genarate report’… the result of the report makes it even more weird.
The report status the first dimention in inch and the rest is correct…:hushed:


#10

I’m sorry…I have no idea at this moment because I am not certain which you desire? (cm/mm/other?)

EDIT:
Maybe I see now…if I copy and paste your text from the Auto-Text Label it displays values correctly…I have no idea why…




#11

@Charlie_v

I don’t have a specific desire of a unit…
I would prefer mm, if cm works it’s also fine by me.
My problem is that the dimention from sketchup to Layout change. (14 cm to 12,7 cm) and (60 cm to 58,42 cm)
Thereby it’s weird that 'generate report puts one dimention is in inch and the rest in cm

EDIT
Thanks for looking at it again,
I attempted kopie paste (also cut paste) the text and at my pc still the wrong dimentions.

Thanks in advance


#12

That is why I thought there might be a scaled component inside the main. Right click and check if ‘scale definition’ is greyed out drilling down the component hyarchie


#13

I don’t know if it affects LayOut behaviour, but metric units in dynamic components work right in SketchUp only if the “display units format” box is checked in the Window>ModelInfo>Units dialog.


#14

@Anssi
Thank, I checked it but the box was already checked.

@MikeWayzovski
I checked that as well and the ‘scale definition’ was not greyed out, so I hit that button, sadly still the same issue.
I also checked it by other components whereby the dimention transfer from sketchup to Layout works fine. Those component have ‘scale definition’ all not greyed out.

By the way I figured out why the ‘genarate report’ gifs one dimention in inch and the rest in cm.
In a sub-level of the component hyarchie I set one attribute (Comp12_breed) on cm and the rest was set on default (text). Ones i set everything to text or decimal in generates cm.
This is far from logic as far as I know… :grimacing: