Dynamic component labelling in Layout wrong

Has anyone have a clue why the height of my dynamic component in Layout is wrong?
See appended LO file…
Schalter_Taster.layout (190.8 KB)

What height are you expecting? It appears the same to me.


If you changed it in SketchUp, did you save it, then Right Click on the model in Layout and select Update Model Reference?

Here I have changed it in SketchUp (Right) and it updated in Layout (Left)


when I enter 200mm in Sketchup:

Layout does not give the same result:


Maybe it is a matter of version? I have the newest version 2023.
Seems that you still have an older version?
And lately I had to update the DC extension…

Yes, I tried the latest version of SketchUp, but rolled back to 23.0.419 due to another bug in Layout (Major grid moving when I clip the grid to the margins).

I thought I had updated my DC extension as well, but possibly it rolled back when I went back to 23.0.419?? I’m not sure how all that works.

Perhaps the way the DC is set up? Not sure what you see when you go to the Component Attributes, but here is what I’m seeing:

The Units are Centimeters, but display is in Millimeters. If you change either one of those fields, does it make a difference?

I tried it before. Also thought it has something to do with inch/ mm change, as in DC you have some trouble with it. I also started SU & LO again, nothing!! Very strange,
is there somebody with the latest version like me? I can only imagine this, as on your computer it works fine…

did you update?

Yes sure. And i habe similar files with the same issue…

I scaled definition of Schalter_Taster_3D in the sketchup file that seems to fix it, can check on your version? it automatically updated

That would be too easy. I redefined scaling,
and also resetted scaling. No way. It is really strange, because I read the data
that I define in sketchup. So I defined a height of 200mm,
the switch will be positioned at 200mm. <DynamicComponent(hoehe)> in sketchup has this value.
In Layout it is wrong. When I add another field, reading the Z value, and then reading it in Layout, it works. Very strange!!!

Schalter_Taster.layout (161.1 KB)