Layout Field of View Control


#1

Hello, I’d like to be able to control the field of view of a Layout viewport the same way is possible in SketchUp – so perspective views in SketchUp can look the same in Layout. I cannot find a way to control this in Layout. Is it possible and I’m just missing it?

These two screen shots show my particular example. The Layout viewport has a high FOV and lots of distortion at the edges. I’d like to match the SketchUp view. Any suggestions?

Thanks,

Valin
SketchUp 2018


#2

Is the view of the doors a SketchUp viewport? If so, change the angle of view in Sketchup and update the scene. Then save the SKP file and update the reference in LayOut. Make sure you aren’t doing anything to the viewport that results in the viewport’s scene showing as modified.

As for the wide field of view and distortion at the edges, this is normal. It happens in SketchUp and it happens in photography with wide angle lens. The way to reduce the distortion is to reduce the angle of view.


#3

Yes Dave, the Layout screen shot is of three separate SketchUp view ports. So the bottom row view is to the SketchUp scene in the top screenshot. When the view port is created I’m having to Edit 3D View from Layout to get it to look as close to the SketchUp scene as possible – what is shown is that result. Thanks for helping.


#4

I’m not sure I understand. Are the top two rows from some source other than SketchUp? If you want the bottom row to match the perspective of the other two rows, you might get that worked out in SketchUp by importing the image.

Frankly, I’d probably make all three rows of doors as a single scene in SketchUp to avoid the screwing around in LayOut.


#5

The top two rows are other SketchUp scenes from the same file.


#6

Oh. I see. Why not put them in one scene? Then the field of view will match. And reduce the angle of view to get reduce the distortion.

Here are three rows of “doors” with the camera set to 135mm. I don’t think the distortion is too bad at this setting.


#7

I experimented on a new page where I Inserted a fresh view port, rather than copying a previously inserted one, and then was sure to select Preserve Scale on Resize, and now the scene in view port looks like my SketchUp scene even after some 3D View Editing.

So I guess some manipulations I’d done to the original view ports corrupted them for these perspective views. Or, I didn’t lock the Preserve Scale on Resize when changing the shape of the view port and that messed things up.

Thanks for taking the time to help me with this!

Valin


#8

Did you use File>Insert to insert that fresh viewport? If so, that probably resulted in two references to the same SKP file which will increase the LO file size.

As I said before, make sure that your viewport does not show the scene as modified after you get finished doing whatever it is you do.


#9

Thanks Dave!


#10

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.