Layout colour profile different once exported to PDF


My Layout models only reflect part of their colour when exported into PDF. This only just started happening and it’s not a full grey scale but really random- please see the attached comparison
SKetchup support request - comparative screenshots Layout vs PDF.pdf (120.6 KB)

I first thought it may be only patterns that I have added hues to that printed grey but it’s not- it’s some solid colours as well. Furthermore, I’ve always used edited patterns and this never used to be a problem. Can you please help?
Here is the Layout file as well
23_01_31 Penton SGD.layout (13.0 MB)


Are you still using SketchUp/LayOut 2019 as indicated in your profile?

This is what I get when I export to PDF from LO2022.

You might try updating your graphics drivers.

I found a few things unrelated to your question but they can be important.

First, in SketchUp, you should make sure all geometry is untagged. I fixed that here.
Screenshot - 2_14_2023 , 9_42_03 AM
And purged unused.
Screenshot - 2_14_2023 , 9_42_20 AM

Purging unused stuff from the LayOut file is also important.



I note that you had copied a couple of images from somewhere and pasted them into LayOut. I would suggest saving images intoa project folder and then inserting them with File>Insert so that you have an actual reference file to fall back on if something happens to the embedded copy.

I would also recommend that you create layers for the content in your LO file. Annotations and dimensions should be added to a layer or layers higher in the Layers list so they are on top of the viewports. That makes it easier to access the content you need to edit or move.

Thanks Dave. I just click on the Layout 2022 Shortcut on my desktop, I have no idea how this could lead me to a 2019 version??.. How do I fix this?

What does it mean to have geometry untagged? I need to put tags on to assign lineweights in Layout.

Thanks for your continued help

I’m going by what you have in your forum profile.

Please edit your forum profile and correct the information. That helps us help you.

Edges and faces are collectively geometry. They should not have tags. You should be creating groups and/or components (objects) to contain the geometry and then give the tags to those objects.

Did you update the graphics drivers and did that help? You’d want to reboot your computer after that update.

Sorry, I created the account a while back and didn’t realise this is where you got the version info from…

I have checked that all my drivers are up to date (they were) and restarted. I also purged SU and Layout. That didn’t make a difference.

I also created a simple test file with coloured patterns in which I put geometry on tags (not groups) and it exports to PDF without a problem, so in principle, that shouldn’t be the problem, unless there are other interactions in the bigger file.

Can I just check that you encountered the same problem with the original file when exporting to PDF that I did?

I’d still like to remove the tags from the geometry to see if that is related- it looks like you reset this with one command, can you tell me how?

If that doesn’t work, it would be good to have the document that you altered and then exported to PDF without a problem to see if it exports correctly for me…

Many thanks for your help!

How did you do that? Did you go to the Nvidia site and compare the drivers with the ones on your computer? Don’t trust Windows to tell you that the drivers are up to date. It’s looking at the ones it automatically installs with Windows updates. They are rarely the current drivers from the Nvidia.

As I wrote:

The purging and tag usage shouldn’t have any impact on the color profile issue. They are just important workflow things.

I did not encounter the same problem with the original file. The PDF export I showed in the first screenshot I showed is from before I dug into your files.

As I wrote before, it’s not related to the color issue. To fix the incorrect tag usage in your SketchUp model I used a plugin called Default Layer Geometry which is available from Sketchucation.

I didn’t save the changes to your LayOut file yesterday. In a little while I will open it and go through it again to clean it up and then I’ll send it back to you. In the meantime perhaps you could update your forum profile to remove confusion.

I sent you a PM with the file since it has client info. You should probably remove the file from your post in this thread, too.

Thanks, I’ll try what you suggested.

By the way, here is another thing: I try to sign into the Forum via Sketchup and the sign in fields don’t come up. This also happens frequently when I am asked to sign back into Sketchup and all I can do is revisit the site and eventually it works but it’s very disruptive…

see screenshot of empty side panel where sign-in fields should be

The forum sign-in is not related to your SketchUp sign-in.

@colin might have some insight into the page you’re seeing. I’m going to suggest that you clear your internet browser caches. What browser are you using?

That’s an e-mail address. Are yuo replying by e-mail?

OK- problem solved!

It wasn’t the driver, although you were right and there was an update that Windows had not picked up on. I changed the PDF export setting from high-quality combined with small file size to medium file size and that did it (that worked with medium and high file quality). I’m sure I used to select small file size in conjunction wiht high wuality in order to not to end up with PDFs that were too large to send, but I’m just glad it’s working…

I’ve also learnt a lot of what I should and shouldn’t do and you’ve been amazing, thanks for all your help and for being so responsive Dave!!

All the best

I’m glad you’ve got it sorted. I think choosing High Quality but small file JPEG compression is like ordering a large mug of tea but insisting it be put into a thimble. :wink:

Glad to have helped if I did.

You can probably use high export quality but turn off JPEG compression. JPEG is designed to work with photographic-style output, and graphics with large uniform areas, lines etc. get very ugly artifacts when it is turned on. Turning it off switches the image output to PNG that has a lossless compression.

Thank you Anssi!

For the blank right side of the sign in page, that’s usually because you have an ad blocker. It needs to be set to allow and to load.

aaah!- thank you Colin. That must be my VPN and the ad blocker that is part of it. I have no idea why it is sporadic then though, because my VPN is set to cut out when there is a loss of connection, so it wouldn’t be the odd lapse in VPN protection that allows the log-in field to come up eventually. Hmmmm…

ha- that’s a good analogy! No quality files in a small Trimble :wink:

1 Like