Layout 24 hangs and flashes when trying to open

Windows 11 home Ver 23H2
AMD Ryzen 7
32G of ram
Layout 24.0.484 64bit

Just downloaded the new SketchUp V24 and while SketchUp opens without any issues. When I try to open LO it hangs and flashes once I try and select a template. Does not matter if I load a file from SketchUp directly, open my own template or try and open a default template.

Removed my (3) custom templates that I copied over to the Layout/template dir, restarted and still no luck.

Filed several bug reports this am. Is there a phone number for Pro lic holders?

Close SketchUp and reboot your computer. After it restarts, find the downloaded installer, right click on it, choose Run as administrator, and then Repair. After it completes, reboot your computer again and see if LayOut will start.

Thanks Dave.

However, after following your instructions LO still hanging after selecting a template.

I also closed the template window and tried to select the “enable experimental graphics engine” just to try but that caused the same hanging/flashing as before.

Maybe @adam would have some input on this.

Your description reads like you have an out of date .plo file, which is very unexpected for a new version release. Try deleting your .plo files as described here:

Hopefully that works,
Adam

1 Like

Thanks Adam. I don’t know why I didn’t think to suggest that.

1 Like

Thanks Adam/Dave.

That fixed it. For some reason I had two UserLayout_.en-US.plo files one was 243 the other 244KB. backed those up in a separate folder, restarted layout and all works now, creating a new plo file with 221KB in size.

Again thanks for all the help, I can now get back to work.

-Jmi

2 Likes