Layout 2022 Suddenly Crashing Constantly - Tech Support Unavailable

Help!!! Layout has very suddenly become wildly unstable and is constantly crashing. I’m a professional draftsman with over 80 current projects so this is an absolute disaster for my business and my very tight work schedule.
The welcome screen no longer appears and layout crashes at startup if I try to launch from the program icon.

I’ve sent in the bug splat but trying to file a tech support request is not working because the tech support website is telling me it’s unavailable. I have many pressing projects which need immediate attention this morning and I’m absolutely shocked at this, Layout has always been stable until now.

Is there no way to contact tech support? I tried a fresh install of Sketchup/Layout 2022 and it did not help.
I tried several rounds of safe boot on the mac mini with no effect either.

has anyone experienced this suddenly severe crashing problem?

Mac Mini system report and Apple crash log included below.

Model Name: Mac mini
Model Identifier: Macmini9,1
Chip: Apple M1
Total Number of Cores: 8 (4 performance and 4 efficiency)
Memory: 8 GB
System Firmware Version: 6723.81.1

Hardware UUID: 578019ED-7583-5463-8BAB-2706770E836F
Provisioning UDID: 00008103-001C15C43CEA001E
Activation Lock Status: Disabled

The (partial) apple crash report is as follows:

Process: LayOut [823]
Path: /Applications/SketchUp 2022/
Identifier: com.sketchup.LayOut.2022
Version: 22.0 (22.0.353)
Code Type: ARM-64 (Native)
Parent Process: ??? [1]
Responsible: LayOut [823]
User ID: 501

Date/Time: 2022-05-25 09:13:50.567 -0700
OS Version: macOS 11.2.2 (20D80)
Report Version: 12
Anonymous UUID: 41FC1688-FE2C-90A1-0049-6596C50D15A2

Time Awake Since Boot: 630 seconds

System Integrity Protection: enabled

Crashed Thread: 30

Exception Codes: KERN_INVALID_ADDRESS at 0x00003e3380e95af0

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [823]

VM Regions Near 0x3e3380e95af0:
GPU Carveout (reserved) 1000000000-7000000000 [384.0G] —/— SM=NUL reserved VM address space (unallocated)

MALLOC_NANO 600000000000-600008000000 [128.0M] rw-/rwx SM=PRV


VM Region Summary:
ReadOnly portion of Libraries: Total=1.1G resident=0K(0%) swapped_out_or_unallocated=1.1G(100%)
Writable regions: Total=1.4G written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=1.4G(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Accelerate framework 256K 2
Activity Tracing 256K 1
CG backing stores 5760K 6
CG image 1504K 28
CoreGraphics 16K 1
Foundation 1024K 8
Image IO 10.4M 28
Kernel Alloc Once 32K 1
MALLOC 244.1M 55
MALLOC guard page 192K 9
MALLOC_MEDIUM (reserved) 600.0M 5 reserved VM address space (unallocated)
MALLOC_NANO (reserved) 384.0M 1 reserved VM address space (unallocated)
Mach message 96K 3
OpenGL GLSL 256K 3
Stack 151.2M 31
__AUTH 1040K 273
__AUTH_CONST 18.2M 466
__CTF 759 1
__DATA 14.5M 517
__DATA_CONST 26.3M 519
__DATA_DIRTY 1952K 219
__LINKEDIT 512.4M 67
__OBJC_CONST 3384K 265
__OBJC_RO 64.5M 1
__OBJC_RW 2544K 1
__TEXT 580.6M 541
__UNICODE 588K 1
mapped file 311.3M 291
shared memory 80K 5
=========== ======= =======
TOTAL 2.9G 3427
TOTAL, minus reserved VM space 2.0G 3427

Model: Macmini9,1, BootROM 6723.81.1, proc 8:4:4 processors, 8 GB, SMC
Graphics: kHW_AppleM1Item, Apple M1, spdisplays_builtin
Memory Module: lp_ddr4
AirPort: spairport_wireless_card_type_airport_extreme, wl0: Dec 31 2020 21:39:03 version FWID 01-1b2645bc
Bluetooth: Version 8.0.3d9, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
USB Device: USB 3.1 Bus
USB Device: USB 3.1 Bus
USB Device: USB 3.0 Bus
USB Device: BUP Ultra Touch
USB Device: Logitech BRIO
Thunderbolt Bus: Mac mini, Apple Inc.
Thunderbolt Bus: Mac mini, Apple Inc.

1 Like

Try repairing your Mac’s Disk Permissions.

  • Choose Go > Utilities.

  • Double-click Disk Utility.

  • Select the volume in the left pane for which you want to repair permissions.

  • Click the First Aid tab.

  • Select the volume where SketchUp is installed, and then click Repair Disk Permissions.

Thank you Adam, I repaired the disk permissions and sadly it had no effect.
Thanks for trying to help.

Experiencing some similar difficulties at the moment, I can’t quite believe that there was only one reply to this pressing issue, and that seemed to be about a piece of adobe software…

Did anyone else get back to you, not shown here?


1 Like

I am having the same problem. No solution until now and a lot of projects to finalize this week.

1 Like

If you use any kind of cloud storage, network drive s, shared drives or even simply iCloud or OneDrive, this can cause all sorts of errors. Try copying a file to a non synced folder and see if that helps

This topic was automatically closed after 186 days. New replies are no longer allowed.