Layout 2022 crashes on Update Document. No bugsplat

Specifically the attached Model & Layout files, no others affected.
Windows 10. Sketchup/Layout 2022.
In LO 9 times out of 10 LO crashes when I try to update the referenced SU model.
I’ve tried repairing the installation and purged unused in LO and SU. Also tried deleting pages in LO to identify whether there is a specific culprit. No joy. I’ve been ripping out my hair, there’s not much left now. I don’t know where to look next, any thoughts or guidance?

Weirdly, after a crash sometimes but not always I have to go through the whole Trimble sign-in process via a Chrome web page again. And sometimes the browser page doesn’t render properly such that there’s nowhere to input my username. My network runs Pihole. If I disable Pihole and reload the Trimble login page then the username field becomes available. Pihole doesn’t seem to be blocking any Trimble nor Sketchup requests however.

Build Manual DRAFT_14.03.2023.layout (9.6 MB)
4011127124_John Owens_A 14.03.2023.skp (3.7 MB)

Are the files you’ve been working on saved llocally on your internal drive? Or are they located on a network or cloud drive?

Does this version of your file behave any differently?
Build Manual DRAFT_14.03.2023 DR.layout (9.6 MB)

Thanks Dave. We use Google Drive, the files are effectively local on C:\ but sync to cloud. That said, google drive has to be running to access the folders and files.
I’ll try out your file tonight.

OK. So that means you are working on files directly from the cloud. That’s a risky thing. There have been numerous cases in which files have become corrupted during saves or auto saves. In your case the crashes could be due to excessive access times during updates.

The general wisdom is to work on files saved to a local (internal) drive and only sync back to the cloud when you are finished working on the project.

You might consider Trimble Connect for your cloud storage. When you open a file to work on it, the file is first downloaded into a temp folder so that saves are done to that local folder. Only when you Publsh back to Trimble Connect does the file get uploaded/saved there.

I would disable google drive’s newish steaming feature and change it to mirror files.

Onedrive does a similar thing and lots of programs do not like it when you try to open a file and suddenly it isnt there and has to wait for it to be there.

You could also try ensuring that your SketchUp files folder is set to be made available offline - this may also reduce the risk of that type of weirdness.

OK, thanks gents. I shall compare performance with the files saved traditionally on C:\ and report back.
It is, however, curious that it’s only this pair of files that are problematic. :thinking:

Edit: just checked settings. Files have always been available offline, so nothing’s changed there.

I’ve now tried with the files on a test folder on C:
Still getting the crashing.

And still without Bug Splats?

According to the specs I can find for the computer you are using, “Dell Optiplex 7460”, the GPU is integrated Intel UHD graphics. Integrated GPUs have never been recommended for SketchUp but one thing you could try that at least wont hurt is to go to the Intel site and get their latest drivers to install. The drivers supplied by Windows might be broken. It’s a fairly usual event anyway.

Still without Bug Splats.

I’ve just tried your version of the layout file, Dave. Still crashes.

All drivers checked, all latest versions. This PC has been good as gold, gets used daily for SU and LO without problems. It’s just these two files. I’ve submitted a request to Support.
Thanks for your assistance.

How did you check the drivers?

There’s something in one of them–probably the SketchUp file–that your computer doesn’t like. Maybe I’ll brutalize the SketchUp model and see if I can find anything else.

Downloaded and ran tools from Intel’s support site.

This ^

Revealing your inner sadist? Or is it masochism? :smiley:

1 Like

Maybe the latter. :crazy_face:

Does this one behave any better?
Build Manual DRAFT_14.03.2023 DR2.layout (8.3 MB)
I removed all of the text and dimensions from the SketchUp model as a test. As I was doing that I noticed in some cases the text was still 3D text and in other cases the 3D text had been exploded to raw geometry. Could be that the exploded text elements are a problem but not the 3D text components.

Additional debugging info:

An empty Bugsplat file is being written to:

Log file is empty

Apologies for radio silence, a lot of life suddenly happened.

Quick update: I wasn’t able to find “the” problem in the SU nor LO files. I tried multiple computers, all of which were using Intel CPUs with integrated graphics. LO crashed on all of them. I rebuilt the files from scratch over a few days and still suffered the crashes. Then I tried them on my kid’s gaming PCs with Nvidia RTX 3060 GPU and it’s “solved” the problem. Seems my latest LO templates are too much for my PCs without dedicated GPUs.

Ho hum. Time for a new machine. I actually prefer Apple machines… looks like a MacBook Pro might be on the near horizon for me.