Layout 2017 is not responding when inserting model

Hi SketchUp team,
could you please help me?
I want to insert my model SU 2017 pro into LO 2017. LO is not responding.
I tried SU–> send to LO
and LO–> insert
Both options LO turns white and is not responding anymore.
What do i have to do to let it work properly

thanks!

So assuming you can open LayOut to a template of your choice, can you draw a rectangle or circle in that document? Another method would be to go to SketchUp, select all, go back to LayOut, hit paste.

Is it a huge model? Try a smaller one first, and see what happens.

hi Barry,

thanks a lot for your mail! yes I can open LO. I just tried to draw a
circle and a rectangle and that went well. LO didn’t go on “not responding”.
Then I tried your copy paste method but that didnt work out :frowning: It had the
same error as before; white screen and LO on not responding.
My files are really small. This is an interior design: like a chair…
Do you have any other ideas what i might be?

Kinda stumped here. Pasting images work? Just wondering if anything inserted into your document would fail? On Mac I could help you (if it hangs, killing the app will create a spindump log)… anyone with more Windows expertise than me have any ideas?

Purge your model of all unneeded stuff:
Model Info > Statistics > Purge All
Then Save the model.
Then on the same panel > Fix Problems
Save the model.

Do you have a scene page setup in the SketchUp model ?
(Scene pages are used as viewports into the model inside LayOut.)

Hi lauradrift-

It may be that LayOut is trying to render the model, and it’s just taking a very long time. How long have you allowed it to stay in “not responding” mode? I know you said it’s a small model, but sometimes there can be unexpectedly difficult models. If you’re able to share the model here, someone else can try rendering it.

Just as a test, try creating a new SketchUp file that’s very simple - I usually make a cube. Send it to LayOut and see what happens. Report back!

Thanks
M

Hi Barry, Dan and Marc!
thanks a lot for your help. i tried the following:
_purge all - fix problems - save and send to LO. still not responding.
_draw cube in SU - save- send to LO. still not responding
_sending old files, which I know for sure I made it in SU2015/SU2016, to
LO2017. LO works perfectly!
_I uninstalled 2017 and installed it again but still the same problem.
_Yess I use scenes, I always do, never had a problem with that.

Thanks,
Laura

Hmmm… this is a bit puzzling.

The next thing I’d usually ask is whether “Send to LayOut” is actually running LayOut 2017, or if perhaps it’s accidentally opening an older version of LayOut. But since you’re seeing the same issue when you run LayOut 2017 by hand and do a “File->Insert”, I can’t imagine that’s the problem.

There’s a slim chance this is a graphics card driver issue - in theory SketchUp and LayOut use the graphics driver the same way, but the memory handling is a bit different. Perhaps you could try checking for an updated driver for your video card? Check with Windows Update, the computer manufacturer, or maybe the video card company directly.

Try creating a document using the smallest paper size available in LayOut, then do a File->Insert. This will limit how much memory LayOut tries to use for creating the rendered image.

You can also run Task Manager and observe what LayOut is doing. Is it using a lot of CPU power or is it just frozen? Is it using a lot of memory?

M

How about posting the cube SKP from SU2017 that failed.

Hi Marc and Dan

In LO i checked “about LO” and it says its 2017 also the first startup
image is a 2017 image.
I just checked with windows update and everything was okay. I also did a
SketchUp Checkup, see attached file. In the summary everything was okay…
Maybe you see something strange?
Even the smallest papersize isnt working. I tried it with the test cube
file.
I opened task manager. I see Sketchup application is always running between
20-35% (total CPU) (even when sketchup isnt open)
after a lot of tests I see sometimes the memory or CPU goes on red, this
happened twice. But usually it stayed normal. Looks like the CPU is not
frozen. I added some print screens of the task manager.
also attached test cube files. SU and LO.
So the moment I want to resize for example in LO it turns white and is not
responding anymore. SU2017 is working fine
thanks again

test cube.layout (131 KB)

test cube.skp (135 KB)

Hi Marc and Dan,

Did you have a chance to check out what might go wrong with my Layout2017?
Would be a great help for me.
Thanks in advance.

I was able to open both the SKP and the LAYOUT file in LayOut 2017.

My machine does not have the same problem you’re having (obviously.)

I also had no problem opening both files.

Hi Laura-

I’m running low on ideas…

In SketchUp, can you “Export -> 2d graphic”? This uses the graphics card the same way that LayOut does. If it doesn’t work in SketchUp, then we have a graphics card issue.

-m

hi Dan, Dave and Marc,

yeah that PNG is my logo, thats okay its actually always like that. But for
some reason the moment a want to eg. resize the viewport LO stops working,
see youtube link. (sorry bad quality) https://www.youtube.com/watch?
v=PAzm8Y6xOn8

yes marc, I can export 2D images. please find attached info about my
graphic card. I think its okay…?
I actually hope the memory was too low so I bought an extra memory card.
But it didn’t help ;-(
I have Windows 10 i thought that might be the issue. But I have know idea
and im getting a bit worried because i really have to make a document of my
model.

Hi Laura-

Thanks for the video. It looks like you were able to insert the SketchUp model into LayOut, but then LayOut froze when you resized the viewport?

I’m assuming the viewport is set to “Raster” render - what happens if you set the viewport to “Vector render” mode?

What happens if you use a style that has “sketchy edges”?

Could you try exporting a 2d graphic from SketchUp again, but first make sure that you have anti-aliasing turned on in the SketchUp preferences (Preferences->OpenGL->Multisample)?

I’m sorry that we haven’t been able to figure this out - is there any way that we can help you get work done while we’re troubleshooting? Do you want to go back to SketchUp 2016 in the meantime?

Thanks,
Marc

Hi Marc,

I changed it into vector mode and it worked! Hybrid too, so I can keep my
textures. so my test file (cube) is working. Then I tried it with my
project-file and although it didn’t go on “not responding” it is working
but very slow.
In SU the “multisample anti-aliasing” is always on 4x i think a default
setting (?) Exporting a 2D graphic is working okay in all Multisample
anti-aliasing
settings so on 0x, 2x, 4x and 8x.
Don’t worry Marc, you guys are truly a great help! Every time it does
improve… :slight_smile:
I was wondering if its possible to teamview? because if I go back to SU2016
it will help for a moment idd for now. I want to know for sure if i need to
fix a computer issue/ windows issue/ bios setting or a setting in SU/LO. If
its an computer issue then i would need to buy a new one… hope not :-I

Hi Laura, I work on the SketchUp graphics team and I wonder if I can trouble you to do one more experiment for me.

Can you open SketchUp 2017, draw a cube, open the styles browser, change your profile widths to 10 pixels, and then orbit around the cube? I’m specifically interested in finding out whether or not SketchUp crashes once you’ve increased the profile width value.

Thanks,
Thayer

Hi Thayer,

Thanks a lot you are helping too!
just to make sure i did the correct thing:

  • SK2017, draw cube
  • styles -Edit-edge settings-profiles changed to 10
  • orbit
    It works fine. no difference…

Thank you for doing this experiment, Laura. This is helpful information.