Layers in model & layout


#1

A frustrating day with something that I am sure must be oh so simple.
I have made a simple model with 1 cylinder & one rectangular solid (a box)
I made each item a group
I create 2 new layers, 1 named cylinder & 1 named box
cylinder is then put on the cylinder layer & the box on box layer, all pretty basic
Turning off each layer hides the items as expected.
Then I import the model to a layout & hope to find that I can have 2 pages, one to show the cylinder only & one the box only & I cannot seem to do this.
The layers created in the model don’t seem to appear in the layout
I have searched the myriad of tutorials but cannot find an answer
I am very new to SU but quite experienced with other solid modelling & CAD systems
Could someone please enlighten me ?
Thanks
Bob


#2

Layers in SU don’t equate to pages in Layout. . . But ‘Scenes’ DO (sort of). . . See: >View >Animation >Add Scene

If you were to Create a New Scene in SU, to represent each viewport that you want to see in Layout. . . Then from within Layout you could insert your SketchUp file, and right click on top of the model’s viewport. That will result in a context menu popping up, from which you can go down to the ‘Scenes’ options, and choose one of the scenes which you set up in SU.

One benefit of that approach is that after you setup your first page in Layout, and insert a SU model into it — From there you can just make a copy of that page. Then on the second page change the scene setting to the other views you want to use. . . this saves having to insert another instance of the SU model onto page two, or subsequent pages. and also helps with layout continuity between the pages (which you may, or may not, want to have).


A word of caution about working with Layers in SU:

Layer in SketchUp aren’t the same as they are in AutoCAD – In SketchUp you should typically try to stay on ‘Layer 0’ ALL of the time. Draw everything on Layer 0, and then when your done, make groups/components of your work. Once that’s done select a group/component, and use the ‘Entity Info’ window to reassign it’s layer placement.

When creating New Scene’s - Use the visibility buttons on the Layers Panel as you see fit. And as an additional option, if you wanted to, you could even change the Style which is used for each scene. Scene’s have style independence which is sometimes useful.

Hope that Helps,

Jim


#3

Thanks for your response Jim, I may be nearly there.
I made 2 scenes on the model, 1 box & 1 cylinder & selecting one or the other worked as you say.
Then in the layout with 2 pages, doing a right click I can also select one scene or the other
But … it changes for both pages & I want 1 page with cylinder & one with box.
I think I am still missing a vital part
Bob


#4

Both pages changing?

That’s never happened to me, and I’m trying to recreate it so I can suggest a fix. But I don’t know what you did to get the results you’re getting.

Can you outline the steps you took in layout.

OR, Upload your Files, and we can work with those.


#5

ok how do I upload the files, I assume you need both model & layout


#6

click on the menu icon, from within the Reply window.

I’m not really sure if Layout embeds the SU model into it’s file, or not.

So I guess upload both if possible.


#7

layer testing-01.zip (172.7 KB)
Both files in the zip
I added a third scene, one with both items in view
Thanks
Bob


#8

I’m afraid I can’t figure it out.

The only difference I can see is that we used different paper in Layout.

When I deleted pages in your doc, on your paper, I couldn’t copy new pages which had scene independence. . . they all changed just as you said.

Making a New Layout on different paper, I am able to get scene independence on each page.

There’s some page linking going on here (in your version), and I just don’t know what the nature of the settings are. I wouldn’t imagine that it would be built into the page itself, but then who knows, maybe the template does have certain properties that are setup as part of the formatting options for any available template.

Other’s will know much more about this than I do. At the very worst, I guess you’ll have to wait for that info to come along, and that probably won’t take too long. . . or, I’ll finally stumble upon it myself, out of sheer dumb luck. . . anything that makes sense to me isn’t working right now, unfortunately. . . We’ll see how it goes.

You might try a different template paper on your end to see what happens.


layer testing-01(jd Alt).layout (110.9 KB)

This layout file should work with your existing .skp file.

BUT, you might have to reestablish the connection by going into. . . >File >Document Setup – References, and choosing the ‘relink’ button. . . It will be red if the link is broken, as I suppose it will be.


We know one thing, you do need both files, it’s not completely embedded… which is nice to know.

Anyhow, I’m going to keep working on this until an answer is found.

Take Care,

Jim


#9

Well your file certainly works. Maybe related to the paper as you say.
It is now gone 9pm here (Aus) so I will tackle it again in the morning.
Thanks very much for your help
Regards
Bob


#10

Ah, come on it’s 2:15am in my time zone. . .

And I too welcome the sleep. I didn’t want to let you down, I was heading off to bed myself when I saw your reply come back in. . . No big deal though, I usually stay up very late. I’m on track with my normal schedule, more or less.


#11

It was as I expected - your SketchUp view in the LayOut document is on a layer that is shared across all pages. You should make the Default layer one that doesn’t display its contents on all pages, and then place copies of the viewport on the different pages. Now that you have only one viewport, changes you make to it show, naturally, on all the pages where the layer is visible. Shared layers are meant for items like titleblocks and autotexts like page numbers.

Anssi


#12

Great Call, Anssi. I see that you’re well rested, or brilliant all the time, or both, you can take your pick.


#13

More help, what a great site.
I did the layers trick & it worked. I obviously don’t understand the layer function in SU but perhaps that will come in time. I thought that layer 0 was the default layer ? but layer 0 doesnt appear in the tray layer listing.
Anyway guys, I seem to have achieved what I was trying to do in the simple example so I will move on to the real job & probably be back some time with a heap more queries.
Thanks a bunch


#14

Layer 0 is the default layer in SketchUp, not in Layout.