Layers and scenes for dimensions

I’ve drawn a cabinet I intend to build. I’ve not yet added any dimensions to the drawings, using only the tape measure tool while drawing. I now want to add views that show each individual part displaying there dimensions.

I know it’s done with layers and scenes (which I have never used). I’ve seen tutorial videos on how to do it but for the life of me I can not find them now. Please point me to some instruction on how to do this efficiently/properly.

What I’ve seen so far seems to indicate that I have to create a copy of the various parts outside of the normal view. This just does not seem right to me, but maybe it is.

Old Rebel Router Table.skp (14.0 MB)

How about sharing your SketchUp model file so we can see how you’ve created the model? That will help to give you an efficient method for creating your dimensioned views.

It depends on how you want to show the parts in your views. I typically create at leat two view if not three views of the parts for dimensioning so I copy the components away from the assembled view of the model for that. Here’s an example from a recently done plan.

The assembled copy of the model is at the origin. I’ve copied the components up above where they are out of the way for views of the overall table. The second screen shot shows the view of the scene I created for the dimensioned views of the parts.

I do the dimensioning in LayOut not SketchUp but in your case you could add the dimensions to the views you create of the individual parts. If you want to show the model with an without the dimensions, you can create a layer to give to the dimensions which can then be turned on or off as desired for each scene.

I uploaded the model in my original post. (I hope this is the proper way to share the model)

That works.

Who will the resulting plan be for? Is this just for you to take to the shop so you can build the thing yourself?

Just for me for now. But if it works out well I may share it with others or even consider selling the plans.

Here’s a quick example from your model.

I copied the components up above the assembled version of the model. I then used Rotate/Copy to make additional copies in 3rd angle projection and then added the dimensions. I gave the dimensions a tag/layer so they can be displayed or not. The dimensions are shown selected in the screen shot just to show that the Dimensions tag/layer is assigned to them.

Here’s how the overall model looks at this point.

You could avoid the copies of the components however you would need to create more tags/layers for the components so that you can clear the model space of all but one component and it would require a lot more scenes to manage. I prefer to make the copies so I can limit the number of tags/layers and the number of scenes I need to manage.

You could also use perspective views of the components and dimension them however the dimensions can easily become extremely cluttered and hard to read.

Keep in mind that with dimensions in SketchUp, you might still want to create additional scenes in which you have zoomed in for the smaller details. For example the dimensions for the T-slot in the fence face is difficult to read when you can see all of the parts in the view I showed first.

You have a lot more control over dimensions and the way your model is displayed in LayOut and it’s much easier to create a multi-page document in PDF form that you can print or share so you might find it worthwhile upgrading to SketchUp Pro for that. If you intend to sell your plans you will have to upgrade to Pro anyway.



Here’s an example of some of the views of the coffee table in LayOut from my earlier post. I’ve turned off the layers for the dimensions and labels.

All of the details from the model come from four scenes in the SketchUp file. All the two-views of the parts come from the scene I showed earlier. That includes the hidden details for the mortises and pins as well as the outlines for the blanks before cutting. In this plan all of the parts are shown at 1:1 in the printed form.


Very helpful. Thank you.

What is “3rd angle projection”?

how do you give dimensions a tag/layer? That is part of what I am struggling with. Once I create a copy of the parts I want to add dimensions to; I make that component unique and add dims to it. However the dims still appear on the original part. It’s layering I’m struggling with. ( among other things. :slight_smile: )

There’s first angle projection and third angle projection. These are methods for arranging 2D views of 3D objects. In the case of Third angle projection think of the part laying in the bottom of a bowl and then sliding the part up the side bowl to get the other views.



See: 3rd Angle Projection | TECHNIA (US)

Exactly the same as giving tags/layers to the components in your model. Select them and choose the Dimensions tag/layer in Entity Info. If you are very careful, you can make the Dimensions tag/layer active in the Tags/Layers panel and then add the dimensions. You need to make sure you keep an eye on that, though, because you can easily make your model very difficult to work with if you forget to set it back th Untagged or Layer 0. (Note I am referring to both tags and layers because in later versions of SketchUp layers were changed to tags.)

Don’t make the copy unique. There 's no need for that and if you make changes to the model later, those changes won’t carry over to the copies you’ve dimensioned.

Don’t put the dimensions inside the component. Leave them outside. Then they will only show in one place.

1 Like

I think I’m on the right track but not quite there yet.

The parts that I’ve rotated are showing the dims for both the rotated and unrotated copies.

I’d like to have a scene for each “explosion” that shows ONLY the explosion. I have the main scene showing just the original master view. I’d like the fence explosion scene to NOT show what is on the main scene. But, all of that is of course on layer0 and turning that off non-displays everything.

What am I missing?

Thanks again,

Old Rebel Router Table with dims.skp (13.9 MB)

That’s because you added the dimensions inside the components which I said not to do.

Your dimensions inside the component.

I replaced the dimension outside the component.

This avoids the problem of redundant dimensions. If you continue as you did, the dimensions make the bounding boxes of the components larger which means things like cutlists will give incorrect dimensions, too.

First of all, you can’t turn off Layer 0 because it should always be the active layer. Since the bulk of your model has Layer 0 (Untagged in current versions of SketchUp) assigned to the components, you can’t hide them.

If you only want to show the exploded view of the fence, you need to create layers to give to the rest of the components in your model so you can turn those.

If this was my model I would create a layer/tag for the fence parts and another for the case. Still another one for the drawer parts and ones for other things like the hardware. I would not create a separate layer/tag for the components in the exploded view. Then for the dimensioned view of the fence parts I would show only the Fence layer/tag and place the camera so those are the only parts that show in the scene. Like this. Then it doesn’t really matter that the assemble or master copy of the fence is displayed.

1 Like

Yes, Unfortunately I had overlooked that last comment.

Now that I have the dimensions outside the components, how do I dimension the position of the holes in the fence? Dim, when outside of the components appears to be limited to point to point lines. I’d like to be able to indicate the positions of the holes as well as the mouth of the dustport which is a 2" radius centered 1" off the edge.

I hope I now understand the layers and scenes as you have described. I changed some of the high level components from layer0 to cabinet for example. I’m concerned that NOT having things on layer0 is a bad idea.
Old Rebel Router Table with dims.skp (13.9 MB)

I also no longer now see a benefit to having the dimensions in a separate layer that could be hidden. Is there a benefit that I’m not seeing since while no longer in the component they are not duplicated?

Inference to the centers of the holes.

The arc in the dust collection opening was exploded. If you fix that so it’s an arc again, you can use its center for inferencing, too.

I used Lines2Arc from Sketchucation to fix the arc in your model.

Why? ALL edges and faces should have Layer 0 assigned to them. (Nothing is “on” a layer in SketchUp.) Groups and components should get layers assigned to them so you can control their visibility.

It might be that you would want to show some views of the parts without dimensions. Give the dimensions a layer makes that easier to manage. You certainly don’t have to do it but it’s not a difficult thing to do and the management of the model is easier if you’ve given them a layer. You might also think about creating close up views for some of the smaller details. You could use several layers then for dimensions. One for the larger details and another for the smaller ones. You’ve already set up a scene for the T-track detail. Those dimensions are cluttered in the Fence scene. You could give those tiny dimensions a different layer than the rest and then swap which ones are displayed for each scene.

1 Like

Good demo with the bowl Dave. Only large bowl I have has water in it!

Thanks. If the parts are waterproof it won’t matter about the water. :wink:

Looks like I neglected to explode my fence before separating and adding dimensions. (actually did this before you taught me to explode in my pantry model.)

Can I save this somehow, or do I just need to redo the fence "explosion view


It’s fouling up my cut list when using the open cut list extension or I might not have even noticed it.

Open the top level component for the fence. Select all of the components and dimensions floating above the assemble copy. Press Ctrl+X to cut the selection to the clipboard. Exit the edit mode for the Fence component and go to the Edit menu. Click on Paste in place.

The CutList extension should only be reporting bottom level components although if you have it set to sort by sub-assemblies, that would give you some extra parts.

where would I find this setting?

In CutList 4.1: By Subassembly