Lagging suddenly started on all 3 of my iMac computers

I didn’t mess with any settings and I’ve been using these computers and files for a while now. On one computer, this morning I noticed a lag that made it unusable. Its a lag from clicking between tools and selecting things. I can orbit just fine. I tried messing with everything the forums say (fast feedback, smaller files). I even opened a very tiny drawing and the lag was horrible. This was on my newer iMac desktop. So then I opened my MacBook, opened the same file. Same problem. I’ve never had this problem before and I’m years in using Sketchup. Is it software related? Was it an update that happened in the last couple of days? I didn’t have this problem 2 days ago on the same file. Is my only solution to use an older version? Can I contact SKUP directly? I’m dead in the water for work now. HELP!

What OS specifically? Updates tend to go overnights if you have set it up to be ‘automatically ‘

Yes, which OS? I have the latest update waiting and I don’t want to implement it if I am going to suffer as you have.

Catalina. I haven’t updated to Big Sur yet.

Catalina. I haven’t updated to Big Sur yet. So if that’s what you’re referring to, not the case.

I realized my computer was lagging on the desktop when I tested moving the cursor around repetitively. I shut down the computer and restarted and it seems fine! Lesson learned… ALWAYS start by restarting a computer. I let you know if it persist on my laptop.

@simoncbevans, I am running the latest update of Big Sur along with the latest build of SU21. No problems.


Ok… new development that explains what happened… Bad news. As soon as I used the 3D Text tool… the lag started again. So I tested it. I shut it down again, restarted… and fixed once again. I used SKUP another 15 minutes to make sure it didn’t randomly happen again. As soon as I tried the 3D text tool… bam, same problem. At least I can draw and continue making a living, but this text thing really gives me a crutch. I have a brand new (1 weeks old) iMac. Could it be a faulty graphics card? Is it likely a SKUP issue? I’m going to update to Big Sur since I feel fairly confident it’s not the OS. Maybe that’ll work? Thoughts from other Mac users?

see my other comment

What font for the 3D text tool?
Did you migrate the new iMac from Timemachine?
Is it finished?

No, I just synced everything on Dropbox. That’s my hard drive these days. What are you thinking with that thought?

Does that mean you are working on files that are saved only out on the cloud?

Wait… You are accessing all your files to and from DropBox over the net? Are your applications there? Are your fonts there?

No. They’re saved on the local drive.

No, I have a 512GB local drive and I’m using 250GB of my local drive to house everything I have on Dropbox. So my files are all on the local drive as well.

I’m using Tahoma, 2" height, left aligned. NO extrusion. NO fill.

Is that a red flag for your knowledge?

BTW. Once again, I’m drawing right now and have been avoiding the text. As soon as I clicked on it to check for you… LAG!

Hmmm… I am not experiencing any problems with the 3D text tool. This sounds like a network or permissions problem with your setup. You might try disconnecting from the web and running your workflow to see if you get any error messages. Try switching fonts and try using Tahoma font in another application to make sure your system has proper access to all your fronts.

I’m a little less savvy than some.

How can I address or investigate the permissions problem? Or network?

What should I specifically do to “disconnect from the web and run workflow”?

I’ll try switching fonts to arial.

Thanks for the help! Also, I’m willing to pay anyone what ever is worth their time to help me diagnose this. Is that allowed on this forum? To remotely look into it? Time is money for me and there are many that would be better at pinpointing the problem.

I was just suggesting turning WIFI off in the upper right corner of the finder if thats how you connect. To make sure your system is not trying to access files across the net that it should be looking at localy. Trying a different font is also a good test.