Lagging for Sketch Up Pro 2018


#1

Hello! I’m using a Sketchup Pro 2018 on the Microsoft surface pro and I’m facing some issues with lagging. May I know how to solve the issue? Have read other forums but can’t seem to find a solution! I am using it with the keyboard dock in. Heres the spec for my laptop

Surface Pro
Processor: Intel® Core™ i7-7660u CPU @ 2.50GHz 2.50GHz
Installed RAM: 8.00GB
System Type: 64-bit operating system, x64-based processor

Thank you in advance!


#2

Check this thread:

Why? Here is everything you will need :smiley:


#3

I cam across this! but I wasn’t sure what it meant :confused: sorry I’m not very good with computers. may I know how to check if I have a built-in gpu?

If it’s too late, and you’ve already got a Surface Pro with only an integrated display adaptor, try going to Preferences > OpenGL > and uncheck the box for Fast Feedback. That should at least fix any issues with a black workspace.

Does this solve lagging or just a black workspace?


#4

In the search window at the bottom left of your screen, type ‘system’ and open System Information. On the left of that window, click on Components> Display. The right hand window should show you the graphics adapter info. There may be more than one.

Try it and see what happens? You won’t break anything.