Lag when returning to SU from another application. Validity Check?


M1 Mac mini 16gb RAM SU 2022

I’m working on a really big project and the file has become almost unusable. It’s generally OK - I can navigate, pan, zoom, open components, draw, edit, sketch really smoothly, even with shadows and materials on.

However, when I go to another application, IE photo editor, layout, outlook, whatever, and come back to SU, it takes forever to “wake up” (sometimes 10 mins of just watching the spinning wheel).

Today I came back to SU from checking my emails, and remembered that the first thing I needed to do was to undo a paste oepration. I waited for the inevitable “wake up” time and then went FILE>UNDO and saw that the option there wasn’t UNDO PASTE, but UNDO VALIDITY CHECK.

Is that why I am having to wait so long when returning to SU?
Is it doing a validity check every time I come back to it?
Can I turn this off?

I’ve unchecked “Automatically Fix Errors” but does that stop SU checking for errors in the first place?



Check your computer’s memory usage. A “really big project” might cause almost all your RAM to be in use, and when you switch applications, they are being shuffled to and fro to virtual memory (disc).

Just thoughts.

My guess is that check-validity is enabled when doing a save, and that auto-save is also enabled, and an auto-save occurred while you were checking email and that save’s Validity Check detected a problem in the model and “fixed” it. Thus, leaving the most recent item on the Undo stack as the Validity Check operation.

Large files (millions of edges and faces) can take quite a while to check their validity in my experience (with SketchUp Pro 2018 and earlier at least). For me with models with a few million edges and faces, it takes about a minute to save. This doesn’t explain why there is a delay at the time when you “wake up” SketchUp, however. That is very curious timing. Maybe SketchUp’s auto-save gets triggered after a period of idleness, rather than after a set amount of time (which is how I thought that auto-save was working).

For that it’s worth, I have auto-save disabled because a) the long pauses to check validity would be super annoying if I was in the middle of an operation, and b) I have read reports that the resulting auto-saved file can be corrupted if there was a modeling operation in progress at the moment when the auto-save began to execute. So I manually save fairly frequently. (I also sometimes make duplicates of the saved file under a new name (copy 2, copy 3, etc.) in case I wish to return to some earlier state that I could not reach via Undo.)

Thanks everyone, and apologies for the sloppy spelling - juggling a lot today! I’ve tidied that up now.

Anssi - my ram use is at around 8GB on this model so I should have headroom there?

TDahl - I thought the same, but the “wake up” happens EVERY TIME I come back to SU. I have Autosave set to 15 mins, but if I check an email and come back even 2 mins later, I still have the wait.

I guess I will try working with only manual saves for a while, but I am forgetful and can see myself losing work in the future!

BTW this model is 18,500,000 edges so I know I am pushing it. It;'s just annoying that once it’s working up it’s as smooth as you like. If I can just get it to not do whatever pesky thing it’s doing I could be much more productive!