Kerkythea Rendering Software for SketchUp doesn't download

Kerkythea for SketchUp


I would click the highlighted link, but for some reason(s) unknown, it would open a new tab but then quickly close after that. And now, it doesn’t even open the tab, it just shows the page with the refreshing circle, but do nothing.
I’ve heard and seen Kerkythea make great renders so I am interesting in it, but I don’t seem to be able to even download it.

If you have successfully downloaded and used Kerkythea, please tell me how. I am in need of a rendering software.
Thanks

Try right clicking on the link and choosing Save as… I have been using Kerkythea for more than a decade but i just tested it and it downloaded fine.

Okay, I shall do that.
Report to you if I works or doesn’t in a minute or so.

It might be a browser setting, try rightclick and copy the link, than open a new tab and paste it and hit enter.

image
thanks @DaveR, saving the link as… worked but I got this
any idea how to get round it?

Perhaps your computer’s firewall or other security settings are preventing a Windows executable image from being downloaded. (Untrusted Windows executable images are indeed a major risk.)

Thanks @MikeWayzovski, opening the link in a new tab worked, but again, for reason(s) unknown, it closed.
Not sure what’s going on…

Maybe, but if so, is there anyway that I can get around it?

If you own the computer (and are thus in charge of all its settings etc.), then yes surely there is a way. You would need to identify what security/firewall/anti-virus software is installed, and adjust its settings. If the computer is managed by a company, you may need to convince the company IT people to make the change. If the business purpose of the computer includes rendering, then I would think an exception would be made.

The posts I deleted are just short messages which may make it confusing for others.


In the image above, I’ve found the link highlighted in blue not working. or rather not “safe” for my laptop to download. the link highlighted in yellow works, but looking at the highlighted in green text, which says it’s alright for 2017 Make, but the downloaded stuff was 2021 Pro not so good for a Make user…
@DaveR, please do let me know how you downloaded it because I can’t.

That’s totally due to your security settings. There is nothing wrong with the Kerkythea.exe download file.

What makes you think it’s “not so good for a Make user”? The SU2KT extension will work fine in Make. It even says so on the page. You highlighted it in green. What made you think it’s for 2021 Pro?

As I wrote before, I’ve been using Kerkythea with SketchUp models for more than 10 years. It has worked with every SketchUp version in that time.


Isn’t it? SketchUp Pro 2021.

That I’ll try by myself, though you won’t see it soon.

That only indicates you have at some point installed SketchUp 2021 and Windows is still associating .rbz files with that version. That doesn’t mean it won’t work in SketchUp 2017 Make. Since you are using SketchUp as a hobbyist and sticking with SU2017, maybe you should remove SU2021 from your computer and cleanup any traces of it including in the registry. Then run the Su2017 Make installer again (right click and use Run as administrator) to make sure Windows only sees that version.

Yeah, I have installed SketchUp 2021 before and the reasoning behind why it’s downloaded itself as 2021 version does make sense. However, I’ve long deleted SketchUp 2021 and the only thing associating my computer to it are


the models in dark yellow highlight with the red line.
I can’t open them in SketchUp Make they claim it was created in a newer version of SketchUp, the only I have is SketchUp 2021. These models are the ones making Kerkythea think that I’m using SketchUp 2021? Do I need to delete them in order to convince Kerkythea that I am using Make or a 2017 version of SketchUp?

You may have uninstalled SketchUp 2021 but evidently you have not cleaned the Registry since then. That’s what is making Windows associate SU2KT# and tt_truebend with 2021. Both of those will work just fine in SketchUp 2017 Make. You just need to install them via Extension Manager.

No. The model files are not making Kerkythea think you are using SU2021. Kerkythea doesn’t “know” those files even exist on your computer. And it doesn’t care what version of SketchUp you have. The SketchUp version will not prevent Kerkythea from installing. It also doesn’t matter as far as SU2KT3 is concerned. SketchUp 2017 Make will install SU2KT3 with no problem. Instead of arguing about it, just do it.

The model files that you saved from SU2021 won’t open in SU2017 because they were saved as the newer version. You could have saved those files back to SU2017 before your trial period expired. You could upload them to the 3D Warehouse and download them again as 2017 files.