'Just a few questions' won't go away

I’ve been trying to download models, but every time I click the ‘Download’ button, the ‘Just a few questions…’ box comes up. I fill out the details, and it shuts down. However, when I click any download button again, the same box comes up, almost as if I never did it. This is frustratingly consistent with any model I attempt to download. I’ve even tried it on the web-based warehouse, and it still happens. Any help?

I just tried downloading a model from a website and it works, no question box.

I wish it would do that for me. No matter what, I always get the popup.

One possibility is that your system is blocking cookies which could make the warehouse think you haven’t already answered.

No I take that back, there is an issue, I’m getting the same loop.
@TheGuz any ideas?

Sorry about the edits. Works fine on Chrome doesn’t work on Firefox.
And yet another edit. Sign out and back in again makes it work.

Thanks for the heads-up @BasilVR and @Box

We’re looking into it.

1 Like

Hey @Box, can you share what version of Windows you’re on and what the version of Firefox is that you’re seeing this issue on?

Would you mind sharing the results for each browser you have? Just curious if you see this in Firefox, Chrome, your native browser (Edge or Safari). This may be Java script related to incompatibilities with older browsers / Chromium, if I were to make a guess.

Hi Jakub, this is on an older laptop running Win 7 and Firefox 78.0.2 84bit
The Chrome version that didn’t show the issue is 84.0.4147.89 (Official Build) (64-bit)

Note: Signing out and back in fixed the problem yesterday and it isn’t misbehaving this morning.

1 Like

I am having the same problem. Running 2020 on a PC and last night it suddenly started poping up the Just a few questions box every time i tried to download a 3D model. Have tried everything i can think of including un-installing and re-installing but keeps asking the same questions as thou i’ve never filled it out. And can’t download…

Thank you for reporting this issue, mark7. It is not the first time I’ve heard about the “interests” survey showing up multiple times.

Can you provide me a bit more information?
Are you attempting to access 3D Warehouse from a browser or from within SketchUp?
What version of SketchUp are you using?

Thank you!

Hey I’m getting the same problem. “Just a few questions” coming up when I try to download a model from 3D Warehouse. I fill it in but it just whirrs, eventually clears then takes me back to where I was. Then the same loop repeats. Same happens on Chrome browser or opening 3DW from within desktop Sketchup. I’ve tried signing out & in again. I’ve made sure I’m allowing cookies. What else can I do…??
Help much appreciated please as currently I’m stuck… thanks.