Why cant/wont sketchup read .JPEG file formats? If you google jpg and jpeg the internet says they are the same. So why won’t sketchup read JPEG?


Which version of Sketchup are you using? Please complete your forum profile.

SketchUp does recognize both .jpg and .jpeg files and has done for years.

  1. And it doesn’t otherwise I would not have taken the time to ask the question.

I have to go into photoshop and resave the file as a jpeg/jpg

It does recognize both.

It’s not just a SU issue.

It’s a general computer thing.

Some systems and languages are case sensible. some are not.
more here :

Basically, SU won’t accept file with capitalized extensions. PNG, JPG or JPEG won’t work.

the solution? simply use lowercase extensions. no need to fire up photoshop, you can just rename stuff.
Why do some softwares still create capitalized extensions, no idea. I know that at some point wordpress had a similar dislike.

You say JPEG / JPG don’t work, and you’re right.
Dave says jpeg / jpg work and he is also right. It’s just a… capital matter.

I’m using materials. When I import like I would a 3d model both jpeg and jpg show up. Is it a line of code that is commented out that both jpeg/jpg wont import while using materials?

When I import images for materials I also do it from File>Import and apply the image as a texture to a face of the correct dimensions. I find it easier that way. I didn’t know you were using the Import feature in the Materials panel. You didn’t mention it in your first post. I don’t know why .jpeg isn’t an option there. I suppose an oversight when they mae SketchUp recognize the file extension.

RE: “I didn’t know you were using the Import feature in the Materials panel. You didn’t mention it in your first post”.

I always have to scale different images to fit different ratios so I just go through materials. Can you have the powers that be turn on both options for future updates?

I don’t have any better access to the “powers that be” than you do. I’m just a SketchUp user who volunteers to try to help other users.

Maybe @colin could do something about that. In the meantime import .jpeg’s via the file menu. You can still adjust their scale.

Also check the colour model used by the JPG/JPEG image. The Windows version of SketchUp, when I last checked, didn’t support CMYK images, only RGB. Happily, conversion between these colour spaces is lossless, as the RGB space is much bigger than the CMYK gamut.

I have run into that problem before but this time both were rgb. Plus you have to manually change color mode in Photoshop. I was literally just opening the jpg and saving the jpg in PS and it worked.

I tried .jpg, .jpeg, .JPG, .JPEG, as RGB and also with CMYK profile embedded. They all worked on Windows.

Do you have an example file that fails?

Did you do this by importing the image via the Materials panel.

Ah! Good point. I will try that as well.

@Colin I sent you a DM with the images

Thanks. After Dave pointed out the problem is only with new material in the Materials tray, I could see that it is missing .jpeg from the file types it can import. Renaming to .jpg makes them work.

I think it was SketchUp 2019.2 when .jpeg was added to the File/Import list. It wasn’t added to the new material file dialog, and is still missing in the latest versions I have. I will create a bug report about that.

The bug report number is: SU-54889.

Thanks @colin @DaveR

1 Like