JPEG format not possible to import


#1

I use a modern copy machine to scan my A3 rawings and I get them in .JPEG file format, but SketchUp do nor recognise this format at all when I try to import it ! Why? I thought .JPG and .JPEG are the same and compatible formats, right?


#2

JPG and JPEG are the same just different extension names. However, the JP(E)G format has several variants. I think I recall having issues with JPEGs in CMYK colors instead of RBG. It could be stuff like that.
Do you have a sample file you can share?


#3

Later . No time no .


#4

Did you change the file format in the import dialogue to e.g. “All supported image types” to see importable images?


#5

Sorry for delay. Now I´m back in business again.
Yes, I also changed the file format in the import dialogue to “All supported image types” to also see the JPEG file. But it is not visible at all. Only files with extension JPG and others are visible. When I converted my JPEG file into JPG format it became visible! My conclution is that there is a bug in the SketchUp. Am I right?


#6

Hmm… it could be that our file type filter is missing JPEG… What OS and what version of SketchUp?


#7

I’m using the latest version of SkecthUp (15) in a windows PC.


#8

Hi tt_su !
Do you still need a sample jpeg file from me? I can e-mail you one if you need it.
The name of the printer/scanner I use is Ricoh, if it helps.
BR/Pekka


#9

No, that’s ok. I’m filing an issue that our file filters isn’t taking into account “JPEG”.


#10

I am also interested in this topic. I created JPEG images using photoshop. I tried importing the JPEG into Sketchup. I am able to bring the image into Sketchup. However, Sketchup doesn’t “see” the image and I am unable to manipulate the design. Does sketchup not recognize JPEG or is there a software problem with Sketchup?

Thanks.


#11

Got sample model or JPEG file to illustrate the problem?


#12

I am attaching an example of a file I would be using. I want to take the outline of the geometric shape and expand it into a 3D representation and use a 3D printer to create a model of the shape. If you need additional information, let me know.

Thanks.


#13

I tried the attached file and it imported just fine under SU2015:


#14

I know this is an old topic, but it was the first that came up with a google search.

FYI - I just had this same issue. Sketchup only recognizes .jpg and not .jpeg. It wouldn’t even see the image file I was trying to import, but saw all of the .jpg images in the same folder just fine. I opened the .jpeg in GIMP and then exported back a copy to the same directory in .jpg format and sketchup immediately saw it.

Sketchup 17 Pro
Windows 10 Pro


#15

they are the same thing, you just need to re-name a .jpeg to .jpg

john