Jagged edges & bugged shadows after videocard upgrade


#1

I tried to use search, found some people who had this problem (Aliasing (jagged edges) with new graphics card & New card and SU15 and all of a sudden I have jagged lines and others). Tried everything and there is no fix for me.

I had GTX 650ti 1gb, everything was working great, but when I got GTX 980 it got really bad. OpenGL 4x anti-alias doesn’t help much and I really need same graphics as it was working before. Edges are jagged and there are weird lines coming out of shadows (on both videocards).

  • Nvidia control panel set to “Let the 3D applications decide”
  • I had clean driver reinstall
  • I tried to use old GTX 650ti on different PC but it has same problem!
  • OpenGL 4x anti-alias in settings http://i.imgur.com/2O9Ogri.png

Here how it looked before: http://i.imgur.com/24eoJRu.png
How it looks now: http://i.imgur.com/antxOEO.png
Bug with shadows: http://i.imgur.com/kIqCgNt.png
Another before: http://i.imgur.com/G6xU3wD.jpg
After: http://i.imgur.com/m6NT3jr.jpg

Will really appreciate if someone can help me.


#2

What does it says for OpenGL support version on the Details dialog for the new 980 card ?
Preferences > OpenGL > Details
Nevermind, I see you posted the screenshot. It says version 4.5.

BTW, the GTX 980 models are ranked 1, 4 and 17 at:
http://www.videocardbenchmark.net/high_end_gpus.html


#3

http://extensions.sketchup.com/en/content/shadow-strings
This extension provides a Shadow Strings Fix toolbar which allows you to toggle on and off a fix for this issue. While this may help eliminate shadow strings, it is possible that other visual artifacts will appear.


#4

I have 4th one, GeForce GTX 980. But it’s the same with the 650. I tried to downgrade the video driver, nothing changed at all.


#5

It might help if you post the Nvidia driver versions, that are showing the issues (so other people with that same driver or cards can compare.)


#6

It fixed one problem, but now there is another - white outline in some places http://i.imgur.com/wfonLRM.png

My current driver 355.60-desktop-win8-win7-winvista-64bit-international-whql. I used 340.52-desktop-win8-win7-winvista-64bit-english-whql to downgrade.


#7

There have been some reported issues with 64-bit Graphics drivers having issues with OpenGL. (Mostly AMD/ATI)

One of the standard solutions is to install the 32-bit SketchUp until these 64-bit graphics issues can be addressed.


#8

Genius! It worked. Thank you very much. :sweat_smile:


#9

I’m here again, with the same problem. 32bit didn’t do much, it only fixed shadows problem. I decided to get my old windows from Acronis backup and to check how it looks there.

Here is a bunch of before and after screenshots:

OpenGL settings: http://i.imgur.com/c4RubcZ.png
Sketchup version: http://i.imgur.com/mCZLaXu.png

Before: edges+shadows on http://i.imgur.com/VkSCftA.png http://i.imgur.com/52pdzD9.png

As you can see edges are very clear and it’s important for me, since I use them as lineart in my drawings! Note that it’s 64bit version, shadows are not bugged and anti-alias is set to 0. I never touched this settings.

Now the most interesting part, I decided what if I will use 4x anti-alias. http://i.imgur.com/xzw0047.png

Quality went to how it look on current PC: http://i.imgur.com/YiFYXhj.png
I set it back to 0, but to my surprice it was all pixelated!! http://i.imgur.com/bXoxPWs.png

I saw that there is difference in “Pixel format”, after I changed settings to 0x anti-alias, first number become “63”, and it was “16” before, when it was looking good.

Maybe I’m wrong but I think it’s because of the “pixel format” thingy. Is there any way to force change it to 16?


#10

What about your display ? Is it High DPI ? Do you have it set to a strange resolution ?


#11

I tested it on pc with yiynova mvp22u (1920x1080) & Dell U2312HM 23" (1920x1080), and on another pc with Dell E196FP 19" (1280x1024). It’s default resolutions for them.


#12

How can I copy OpenGL settings from other windows?