Jagged circles when editing in-model component bug?

bug
components
help

#1

Hi everyone,

I am extremely new to Sketchup (just downloaded yesterday), but I am trying to use it to design a product display model. It’s not very complicated, with several acrylic compartments, and I have been doing pretty well with the program. So far, I’ve just been making the components, then deleting them from the 3D space, and then making more. My thought process is that I could then be able to re-insert the components once I have every component finished.

I saved my project yesterday as an .skp file with several components in it. However, when I opened it today, I inserted one of the components I was working on yesterday and tried to edit it, the circles (40 segments) that were previously displaying correctly deformed and became jagged. This only happens when I am in the component edit mode, and when I exit the edit mode, it returns to normal. Is this a bug, or am I doing something wrong? I would appreciate any help as soon as possible.

Thanks,

James

P.S. I am really not familiar with the orbit and pan interface of SU. Why have acceleration when zooming and panning/orbiting instead of absolute rates? Sometimes when I am in the middle of a part, it zooms/pans so slowly that I have to change the view completely before I can move again. Is there any way to change this?

Edit 2: It seems that I can upload multiple screenshots now, so I have attached them below.

Edit 3: I forgot to mention that this only happens in the file that I saved yesterday. I doesn’t happen when I open a new SU file.


Figure 1: Clean holes on box.


Figure 2: Jagged edges of circles when in edit mode.


Figure 3: Close-up of clean lines when not in edit mode.


Figure 4: Close-up of jagged lines in edit mode.


Figure 5: Entity info to show that this is indeed a circle (40 segments)


#2

That does look a bit strange. Can you upload the problem .skp file?

When zooming out and in, be careful where your mouse is pointing. If you zoom in close and there are only edges and no faces, zooming out can be really slow. Creating a temporary face to point your mouse at while you zoom out can help.


#3

Hi McGordon,

Here is the problem file: Design.skp (222.2 KB)

I appreciate your help.


#4

You have changed the drawing axes to be very far from the model origin, and this is causing strange effects in SketchUp’s rendering. Before placing an instance of a component, right-click on any of the axes and choose “reset”. Then zoom-extents to recenter the view on the model origin. Subsequently, instances you pull from the components window will edit normally (you will likely have to zoom extents again once there is some actual content in the model).

axes


#5

slbaumgartner,

Thank you! This is the solution I was looking for. I guess I zoomed too far from the original and forgot about it yesterday. If I move the origin using the origin tool, does that reset the original origin point or does it just make it so that the axes show up in a different spot?

Thanks,

james


#6

It just makes the visible axes show up at a different spot. The reasons are a bit technical and potentially confusing, so bear with me…

SketchUp at all times has two sets of coordinates: the global, or model coordinates, and the “active” coordinates (aka “sketch”, “drawing”, “working”, etc.). A coordinate system is also known as a set of axes, which means an origin point and orientations of red, green, and blue directions from that origin.

The model coordinates are fundamental. They cannot be moved or reoriented. All content in the model ties back to model coordinates via one or more transformations. This was a design decision, because changing the model coordinates is effectively equivalent to moving the model contents by applying a transformation.

The “active” coordinates are what you use for reference while drawing (which is why they are often called “drawing” coordinates or axes). By default they match the model coordinates. But to facilitate drawing operations they can be moved or reoriented. For example, they are automatically changed to a component’s local coordinates when you open a component for edit because you usually want to add or modify the component’s contents relative to existing contents. You can also manually change the drawing coordinates by actions such as right-click menu on an axis or via the Tools->Axes menu item.

Temporary drawing axes can be a major help when adding new geometry to a model. For example, if geometry needs to be aligned to a particular direction, if you set a drawing axis in that direction you can use the arrow keys to lock inferences that way.

But if you modify the axes manually, it is important to remember you did so and to reset the axes as soon as you finish the drawing operations that needed them. Otherwise, strange and confusing things can happen - particularly if the temporary origin is too far from the model origin and the geometry you are seeing is small compared to the origin distance.

There is no visible flag in the model indicating that you are using transformed drawing coordinates. The fastest way to check is usually to right-click an axis and see whether the “Reset” item is available (not grayed out).


#7

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.