Issues with making a simple model solid

Hey guys and gals,

I have been trying for far to long to resolve a simple issue of my model not being solid. Models do not get much more simple than this one which is why I am confused. I am needing to export this in a .dxf file to have laser cut, but not being a solid it is not working.

I have spent a good bit of time researching the issue but I am not that savvy with Sketchup as of now. I downloaded Solid Inspector and Clean up, but when I run the extension they delete the entire model.

Any help would be greatly appreciated!



In order to be solid it has to have some thickness. Your model doesn’t. You also have excessive nesting and the musical notes can’t touch the rest of the shape at just one point. The note on the left doesn’t even touch the shape.

How thick is this thing supposed to be?

Thanks for the quick response. I have done a few things so far.

The model was originally 1/4" thick - still cant make it a solid.
I’ve removed the music notes from the model - still cant make the main plate a solid.

I used the line tool and the circle tool to make the entire model.

@DaveR is correct about why it can’t be a solid (he beat me to the post). But that shouldn’t have any bearing on exporting it as a dxf. I exported with no issues reported (it is too big to upload here, but it worked).

Give it the 1/4 in. thickness and then make it a group or component.

And Steve’s point is good. If you want a DXF, it doesn’t need to be solid anyway. If you’re planning on using it for a toolpath for CNC cutting or something, just make the whole thing flat.

Thanks I will give that a shot.

The .dxf file is showing breaks in the lines and curves

WAFFLEHOUSE1.dxf (63.6 KB)

This is my first time sending a ready to cut .dxf file to the machine shop. It will be the tool path for the CNC laser. I believe I need to make it a solid so that I can use the union tool to join the music notes with the main base, right?

Thanks again for all the help!

On close inspection, I see some issues in the dxf with both real curves and the SketchUp segmented representation both being exported:

I’ll have to check, that may be fixable by choice of export options?

Edit: in the export options, turn off faces to get rid of this doubling effect. The curves are exported as true curves, but the faces get the segmented effect from their boundaries, which aren’t handled as true curves.

No. Since you only need a 2D shape, you only need to place the musical notes and the main shape together and erase the edges where they overlap. Consider that they can’t meet at a point or the notes won’t remain connected to the main shape.

How will this be cut out? You need to find out what the minimum distance is between cuts to retain metal. How wide is the cut? Which side of the line is the cut to be on or does the toolpath define the centerline of the cut?

I just made the base a solid! I removed the music notes, exploded, made a new component and clicked outershell.

I would end up deleting the entire note or base plate when I tried that, this must be because they were already grouped together. (481.6 KB)

Ungroup every\thing.

By the way, you need to be using SketchUp Pro or SketchUp Shop, not SketchUp Make as your profile indicates.

SketchUp Pro is soon to come. Make has been great to show renderings to clients and has worked thus far.

Except you’re violating the license agreement. Make and SketchUp Free are not licensed for commercial use.

Thanks for the file, that looks so much cleaner than the original.

Are the music notes part of the tool path in this file?

Wow, great point. Clearly I’m not a regular user of SketchUp but nonetheless, looks like I will be buying Pro today.

Cool! Then you’ll be able to make even better presentations to your clients along with shop drawings and full scale patterns because you’ll have LayOut.

1 Like

I’m not knowledgeable on how laser tool paths are created from a dxf so I can’t answer that, sorry!

Thanks, yall have both been a huge help. I really appreciate your time!