Issues with dimension tool

#1

When I use sketchup for piping (quite often) I am unable to use the dimension tool upon the line out of which the pipe was originated unless the pipe lies on one of the three planes.
It looks like the dimension tool wants to measure on one of the three planes, and I can’t get it to pull out a measure parallel to the core line.
However, if I use the measure tool upon the surface of the pipe it will pull out a parallel dimension.
Is it possible to obtain the same dimension working on the core line ?

Here’s a couple pics of the pipe

Here’s an example of the problem. The correct measure is 393,5mm but I can’t manage to obtain it when I measure the core line of the pipe. To obtain the correct measure I have to place the measure tool on the pipe surface, and this is not always possible/convenient.

0 Likes

#2

can you upload the skp file to help people, willing to help you…

john

0 Likes

#3

Here’s the sample file. Same one as the pics above.
Measure_tool_issue.skp (1.4 MB)

Another problem I have with measures, is there is no angular dimension tool, so I have to use the protractor which only measures angles in the console, so I have to use the text tool to manually “print” the angular measure in its place. The problem is when I pan/zoom/orbit the object, the measure (text) I inserted doesn’t follow the object, therefore resulting useless.
Is there any way so I can “tie” the text to a specific area of the object ?

0 Likes

#4

Have you tried Angular Dimension 2?
https://sketchucation.com/plugin/1879-angular_dimension_5

0 Likes

#5

You might find it easier to do the dimensioning in LayOut. And LayOut has a native Angular dimension option.

You’ll find it easier to add the dimensions in SketchUp if you create faces to help guide the position of the dimension. You can delete the faces afterward. Here I pulled the center line of the tube out so I could temporarily hide the turbe and work with just the center line.

0 Likes

#6

How did you temporarily hide the tube ?

0 Likes

#7

Right click on it and choose Hide.

0 Likes

#8

better still, put the spline and the tube on separate layers…

turn off tube layer…

john

2 Likes

#9

I created faces but still get the same problem. It starts measuring in the right direction but when I touch the bottom lines it moves to another plane…

0 Likes

#10

are you bending manually or using the data to setup a programmable bender…

I would do the dimension differently for each method…

john

0 Likes

#11

I build lines then create the bend to desired radius using mostly 2d fillet plugin or arc tool sometimes.
Then I extrude with pipe along path

0 Likes

#12

Pipe is bent on a manual bender and I use hardcopy prints for reference and checks

0 Likes

#13

I’m open to suggestion, but the structures are rather complex. The file is just a small part of it

0 Likes

#14

I solved the problem of the angle measures with angular dimension plugin

0 Likes

#15

Have you looked at Profile Builder 3 from Mindsight Studios?

0 Likes