Is there trick to know how to update my 3D warehouse models?

I’ve tried a couple times to update model but it has always cleared the Likes Views and D/L counts. Last time there was actually an Update button to click but haven’t seen again. All I see is upload file link is that the way it’s done? Don’t see the Save button come into focus unless I change the text. I figured this is why I see so many duplicate looking models from same person. Does it tale some time for the Upload button to appear and I’m not waiting long enough?

Surprised to not see any response. Anybody out there?

You need to save the model after you upload it. Then use that exact saved model to update it again. If you do not have it handy, first download the model from the 3D Warehouse yourself, modify, and upload: the information for the name and description should be there, and it should say “update” instead of upload.

1 Like

Thanks for the response.

I was there when you responded and have been trying your suggestions

I tried with the file I uploaded yesterday. Deleted an item and saved file. When I try to update all that is available is upload new file link.

So I went the other way and tried to download my own model and now have bunch of questions to answer that weren’t asked for in the past before I’m allowed.

I downloaded file and saved to my original filename (overwriting original file) and only option still available is the upload new file link.

You are using SketchUp, not a browser, to upload, correct?

Yep SU17

You’re somehow destroying the Warehouse link in the skp file. When you upload a file to the warehouse, you should notice the file is dirty
You have to save it or you are throwing away the saved link to the warehouse. It appears in 2020 that we’re auto-saving for you: I didn’t have to save, and the model wasn’t marked as dirty.

You can find the embedded model ID in your skp file.
On a Mac, I find it by hexdump’ing the binary:

hexdump -C my_file.skp | grep -A 8 W.a.r

You’ll get something like:
|.e.l.I.D… 6.|

So this is either my model name or an embedded model from the warehouse in my file. I can take that ID and paste it in a url, and I get this:

As I said, if you’re not getting this… we’d have to dig deeper to find out on your machine what’s stopping you from updating your skp.

Just tried it on 17 on Mac (your profile says Win 10), and it worked for me. Got the update instead of upload button, and name & description filled in from previous. Someone on Win 10 / 2017 want to confirm this works for them?

I’m destroying? Honest wasn’t me LOL

By dirty do you mean when I do first U/L SU sometimes says there are unused items, components, etc. do you want SU to clean? Of course I say yes or it won’t U/L (I wouldn’t know where/how to clean - clean probably isn’t the exact word used).

I could see if SU cleans I wouldn’t have exact same file on my machine. SU isn’t cleaning on my machine so then it sounds like I’d have to D/L and save every file when there is SU cleaning being done? How would anyone think of that?

Yep win10

No, I mean save your file. Upload to 3D Warehouse. Save again, before closing. Quit SketchUp, open again, open that file, try to upload, and it should be an update, not an upload.

I didn’t point out that I’m not always asked for a cleaning. File just gets U/P’d as is.

Yeah got what you meant, we’re in agreement about when to save (I didn’t know this until now though). But after that what you describe is quite a procedure to go thru (S, QSU, OSU, wait for SU to load, get back to public page, find/open file). I can see now why there appear to be so many identical models by the same person. No instructions about requiring a file save after U/L before quitting (for each file U/P’d) and no simple way to clean. They’d just go with the simpler upload. I prefer to keep track of likes, views and D/L count in one place.

I just went thru the procedure with a slightly modified file with same name and still get only get upload file link. As I mentioned in original post I did get an Upload button one time but don’t know how it happened. I tried back then to go thru same routine but then only got the upload file link.

Thanks for the time and suggestions. I’ll just have to muddle through it and see if I can sort it out.

We could force the issue if we disallowed uploads from browsers, only go through SketchUp client. And one would think if you’re updating a model, you’d open the same model. Short of sitting at your machine, I don’t know what’s keeping it from success. Good luck.

2 items

1st; My icon in the gray Sketchup Community bar at top of this page indicated new replies one of which was DaveR but I see no posting. I appreciate all your feedback and would like to hear your suggestions/opinions.

2nd; I posted a new model yesterday and did all that was suggest here so far but doesn’t work. After my U/L I D/L’d SU’s ver. and file had been renamed. I saved that file and filename, did a couple minor revs and tried to update using that new SU filename but all I get is opp to U/L but no opp to update. This seems like a MAJOR bug that should be addressed by SU crew unless all that’s wanted is some large volume of models with minor variations from the same contributors.

OK, I think I found the answer. When in My Public Page I’ve been selecting the model I want to update. On the pop-up model page at the bottom it says “See more details” which is clicked on and the model page opens. Below the image and title there are 3 vertical dots and when clicked on there are 2 options 1) Edit Model and 2) Analytics.

Well, like an idiot I’ve been using the Edit Model link thinking that’s the obvious link to use for updating a model. Wrong! What has to be done is have the model you want to update open in SU. Ignore the common sense of wanting to “edit a model” and instead use the Upload link in the upper right corner by your icon ignoring the concern one might have about uploading another copy of a previously uploaded model because now when you select the upload link it changes to a page to up date your model.

And guess what else, it can be done anywhere there is an upload icon link, just as long as you’re ready with the model you want to update open in SU.

So what’s with the Edit Model link being the seemingly obvious choice but doesn’t work but any upload link that doesn’t indicate anything about updating does work? Maybe the “Edit Model” should be changed to “Edit Text Info”?

I guess I’m the only one to pull-a-homer on that one since there’ve only been a few helpful suggestions. LOL