Is there a "paste in front" like in Illustrator?


#1

I am working with a surface on a computer monitor and want to make a reflective layer by copying the object with the screen image and pasting it on top and then assigning my material to give it the glass look. My problem is that when I copy and paste, I can’t place the new object in the same place. Is there some way to copy and then just paste the object right where the original is instead of having to move the cursor and put it in place (which never works)?


#2

From Edit select Paste in Place…


#3

I tried that but it didn’t work. I watched a video on it and it seems like it is something else. I tried the paste in place but all that is there is the original object, no copy.


#5

If you delete the original, then paste in place, does it appear to come back? That is, if the copy is exactly where the original still is, things would look the same.


#6

I can think of two possible explanations. The silly one is that, of course, you have to copy the geometry using control-C first before there is anything to paste! The more subtle one is that if the geometry is not a Group or ComponentInstance, SketchUp will detect that the pasted entities are duplicates of existing ones and will discard them as it cleans up. And, even if the geometry is a Group or ComponentInstance, the copy will be pasted exactly atop the original so you won’t be able to see it unless you associate the original with a different layer.

But even more to the point, in SketchUp you don’t put a “layer” over something to give it a surface appearance, you paint it with a material/texture using the paintbucket tool. There is no need for a second set of geometry to do this.


#7

You might be right there slbaum. I made an object of an iPhone and have an object for the screen. I am trying to copy and paste it in front so I can in effect put a relfective glass coating on top. What’s happening is that nothing seems to be getting pasted. I do the paste in front and then apply my material settings and it acts as if only the 1 screen object is there. If I go and move it, I see that there is only 1, not 2.


#8

If you can upload your model, we may be able to give you specific advice.


#9

something like this?


john