Pasting Into New Layer

Learning here and used to Illustrator so I have to think differently. I am trying to copy items from one layer and paste them into a new layer. However it keeps putting it back in the original layer…? I’v tried it as a component, hiding layer and not component items. No luck, always goes back to the original layer.

In SketchUp layers are not like boxes you place things in, but attributes you apply to things. Instead of layers, use groups and components to organize the model.

First off, make sure you understand what SketchUp Layers do and don’t do. They are not like CAD layers and don’t organize anything except by providing a flag that makes multiple things visible or not at the same time. See, for example,

https://help.sketchup.com/en/sketchup/controlling-visibility-layers

That said, the simplest way to assign a different layer to one or more entities is to select them and then change the Layer field in the Entity Info window.

1 Like

Okay, just a new way of thinking. Now when I copy one component to another file, part of the component is missing…

How about sharing the two SKP files so we can see what you’ve got going on?

That sounds like a case of having some of your geometry on a layer other than “0”.

Many new users find the video tutorials helpful.

Components


Layers

1 Like

Granted, layers are only for visibility. But it is difficult to make a copy of a component and add to a different layer, while keeping the same position.

I’ve tried pasting-in-place and reassigning the layer for a component, but both the original and the copy were assigned to the new layer.

The alternative is to paste with offset. In that case, only the selected element is assigned to the new layer. As long as both layers are visible, it can now be moved back into it’s original position, but it would be nice to have the option to select the visibility layer when pasting!

Don’t think of layers as places but as properties. You can’t paste “into” a material, but you can place and then repaint. Same with layers really. What you place into, and what separates the object from other objects as layers do in other software, is the groups and components.

I think you’re missing something because it is possible and easy to paste in place and change the layer association for only the copy of the component. Immediately after Paste in place while the new copy of the component is still selected, change the layer association in Entity Info. This will only affect the selected instance of the component. It will not change the layer association for the instance the copy was made from.

I haven’t seen a “paste in place” option. Would love to see it working the way you describe.
What happens for me:

  1. I paste, and see nothing.
  2. I move the cursor a little. The item appears a little way off.
  3. I move that item to the original position.
  4. After the move, the lines all join together, so there is now only one item.
  5. Assigning the selected item to a new layer now moves “everything”.

I’m on Windows 2000 with latest updates, running the desktop implementation.

The trick, I think, is to change the order slightly:
1. Paste
2. Move the cursor so you see it.
3. Assign it to the new layer.
4. With both layers visible, move it back to the original position.

What do you mean you haven’t seen a Paste in Place option? It’s in the Edit menu. You can assign a shortcut to it as I have.
Screenshot%20-%208_16_2019%20%2C%203_04_38%20PM

Too much work.

The trick is to use Paste in Place.

Copy the entity.
Hit Paste in place.
While the pasted copy is selected, change the layer association.

Using keyboard shortcuts it goes even faster.

2 Likes

Dude! Thanks for that!

It must come up when something is on the clipboard–a time when
I never visit that menu! (That’s my story, and I’m sticking to it.)
:__)

eric

MeditateBetter.com
author of Bench Yoga

650 814-0370