Interrupt SU when apparently frozen?

Could there be a way of stopping a process that is taking too long, and exiting it without having to Force Quit?

I’m trying to work with Scott Baker (@NewThinking2) on his huge model. Every time I try Zoom Extents, SU goes into an apparently endless ‘Wait’ with spinning (Mac) ‘beach ball’.

The only way out seems to be Force Quit.

Could there be some key that long processes check - say every 30sec - to show whether it is just slow, or frozen, and offer the option just to cancel?

Out of a several hour session today with this model, with about 90% of its tags turned off so not visible, I’ve spent what feels like nearly half and is probably realistically a third, just waiting for SU. Which appears frozen, but eventually isn’t, but only most of the time. This time I’ve been waiting ten minutes for a Zoom Extents (not) to finish. About to Force Quit, since SU seems frozen.

I should have save more recently. Now I can’t.

1 Like

I agree it would be good to have a stop button.

But that has never been a possibility with the arch.

Maybe it would be a good idea to work on smaller parts in separate files and merge them at the end to prevent this?

In my experience it has never crashed, it just sometimes takes longer than you are willing to wait.

1 Like

Just to continue @Cotty 's train of thought, way back when one of the many versions of new thinking started this extravaganza, many suggested an approach that involved combining workable models into a whole. The concept was rejected and many who could have helped simply didn’t.

1 Like

Well, to be fair, a few things either prevented that solution, or are would not be solved by it:

  1. The actual model itself - walls, floors, that is, everything either I or John actually created, is not usually that intense on resources. A 1000’ wall is mostly nothing. OTOH, I imported a lot of 3D warehouse stuff for the apts. and elsewhere - like a Farmer’s Market, imported whole, and apparently the source of millions of edges. Of course I test these out in an empty model first, both for size in MB and also to make sure they don’t add unnecessary layers, but that is not the real problem here. It’s just the churn of drawing all those angles whenever they are turned on.

  2. Every floor is a little different and it’s really hard to figure out exactly how outside of the model. So when designing apt. interiors - which I only did for about 1/10th of the floors - I use the tapering walls to show me how to reconfigure apts. Again, it’s the stuff inside the apts. furniture etc. that is the culprit in time, though John has simplified a lot of this from the warehouse.

  3. The angles of the arch seem to take a long time to resolve visually, so there must be a lot of calculating going on. These “shells” are actually 20-50 floors long, curving in a programed way with Ruby or other code John did, or in some cases me, though I mostly worked at the detail level. I guess that’s a clue.

  4. There’s an especial problem with text. If there’s text anywhere in the model and you Zoom Extent, forget-about-it. The model goes into some kind of infinite loop. I have to be careful never to have layers (tags - I can’t get used to that change yet) with text off. Mostly, I just never use Zoom Extent.

Do you like my new rendering? Hmm, pretty…though there’s water where there shouldn’t be. Oh, that’s the last problem:
5. Placemaker was used to create all the surrounding buildings. It works reasonably well, but it added about 200mb to the file to blow it up to 700mb. It took me 6 tries to find a renderer that worked: Indigo Renderer.

If that is directed at me, I’m not going to read it.

It was more directed at SU and is in the spirit of constructive criticism.