Install Problem ThumbsUp.dll

This drastic step should never be necessary just to solve an application installation issue.

(1) Run Windows update and be sure all updates are done.

(2) Go to this post and follow instructions to install the Microsoft library dependancies for SketchUp 2017:
Unable to install SketchUp Pro 2017

(3) Then re-install SketchUp 2017, by right-click and “Run as administrator”.

Hi, I have done all that you described but the problem still remain. What you supposed to do?

For more information, I have on my PC other installation of Microsoft C++ Visual Redistributable

What version is this other MCVR ?

StartMenu > Control Panel > Programs and Features

Hi,I attach the differents versions of Microsoft C++ Visual Redistributable so you can help me.thanks


----Messaggio originale----

You have the needed MS C++ Runtime version (14.0.24215.1).

Are you positive that you install SketchUp 2017, by right-click on the exe installer, and choose “Run as administrator” from the popup menu ?

Did you try the “Ignore” option when the install "failed to register “ThumbsUp.dll” error came up ?

Yes, I have try all of that you said.
Run as administrator and ignore after the problem appear. After that is not possibe to open the program.

Some others having the same issue, found success by uninstalling the Microsoft Visual C Runtime (version 14,) and re-installing it.

Just like all software, the installer should be run using elevated privileges. (Right-click and "Run as administrator.)

Sorry but this is not useful for me. I have installed again the Microsoft Visual C Runtime (version 14).
What can i do?

It worked for others. Sorry it has not worked for you.

@stefffffy, what is your graphic card? Do you have an integrated Intel graphic chipset?

Hi, my graphic card is Nvidia Geforce GT 740M and an intel core i7.
Can you help me?

We can try.

Have you updated your card’s driver?

On laptops, by default the integrated graphic chipset is used to save power. Open the Nvidia control, go to the 3D settings menu. You should have the ability to customize settings for each program. Check that the Nvidia card is being used for SU.

Hi, I’m in the same situation with ThumbsUp.dll.
My setup : Windows 8.1 pro, Intel HD Graphics 520, Intel core I7.
I already tried :

  • Updating graphic card driver
  • Desinstalling/reinstalling MS C++ runtime version :
  • Run as administrator
  • Ignore the message and run sketchup : new message :
    “System error / Impossible to start the program, api-ms-win-crt-runtime-l1-1-0.dll is missing. Try to reinstall the programm to solve the problem”

Is there any reason that Sketchup does not support my graphic cards? Do you have any idea of what to try next?

Thanks and regards,

Run Windows update and get all updates to the C runtime.
IF it does not work, you’ll need to repeat process until it does.
OR get help from Microsoft Support to get the runtime(s) installed correctly.

Just for information, I finally succeed running sketchup!!!

I have manually installed KB2999226 update for Windows 8.1 (it seems my automatic windows update is not working well) :

Then I ran Sketchup installer as administrator, ignored the ThumbsUp.dll message and launched sketchup and surprised, it’s now working!

Thanks for your help,

1 Like

@stefffffy You also should be sure to run update KB2999226 if you have Windows 7, 8 or 8.1:


Installing this update fixed the problem for me , Thanks


Same problem with Windows 10 and SketchUp Make 2017!

To solve the problem I uninstalled all “Microsoft Visual C ++” using the “Programs and Features” !

I am afraid that many users find themselves in the same problem and end up abandoning SketchUp without finding the solution.

What do you think ?

See you


Another case of 2017 Make and Windows 10. I just removed all Visual C++ versions and tried another (run as admin) installation of Sketchup Make 2017, but I still get the ThumbsUp.dll error.

Sketchup worked for me fine in january, so I’m guessing this has something to do with Windows Update? Or an incompatible app? In either case, I’m up to date (on 1909 Windows 10, 2004 isn’t ready for me yet).

If anyone has any other possible solutions, I’m all ears.

EDIT: installed it on another (2004) PC, no problems. And in a 1909 virtual machine, also no problem, the app also starts with no issues (unlike on my PC).