Inserting a text label causes Sketchup to crash, why?


#1

I am a beginner trying to learn the ropes. Every time I insert a text label it crashes Sketchup. What am I doing wrong?

TIA,
BWSwede


#2

OK, I think I solved that issue. My drawing was huge so I purged it and it dropped down to 274 kb. Now that I can make text labels without crashing I have found that I can’t read what the label says. Above the line of text in about the same size area it looks like cross-hatching. Below that is what I believe to be the text.

Does anyone know why the labels are not legible?

TIA,
BWSwede


#3

I increased the size of the text to where it is somewhat readable. I say somewhat because over the top of what I write is the area of the entity the leader points to. And, I still have a cross hatched box the same size as my leader text located directly above.

What is going on?

TIA,.
BWSwede


#4

Attaching a SKP file or a screenshot of what you are experiencing would help.

Test your graphics driver for OpenGL deficiencies. In SU, go to Window > Preferences > OpenGL and disable hardware acceleration. If that fixes the problem, try updating your graphics driver.


#5

Cat,
Thanks for the reply. I tried what you suggested and it made no difference.

I have attached an skp file and when opened you can very clearly see what I am talking about.

Thanks again,
BWSwede

Selfservice Model 4 4 15.skp (446.4 KB)


#6

The text look fine at my end. What do you see?


#7

Maybe you should ask for a screenshot? :wink:


#8

This could well be a Graphics Card issue ?
Especially if the attached SKP opened by others displays none of the OP’s issues…
So…
What is your Graphics Card ?
Does it have the latest drivers installed ?
If not get them, then restart SketchUp to see what happens…
If it’s an NVIDIA, is its control-panel set up to let the 3d-app decide on settings ?
In SketchUp’s Preferences > OpenGL tab have you tried adjusting the permutations of settings to see if that improves the display ?


#9

Thank you for the replies. The file below is what I see.

TIG, I’ll let you know what I have and try what you suggest. Since this is beyond my skill level it may take me a while.

Thanks to all.

BWSwede


#10

My graphics card is a NVIDIA GeForce 9500 GT
Main driver: nv4_disp.dll
Version: 6.14.0013.3528
Date: 3/9/2014
DDI Version: 9 (or higher)

I am not computer savvy so I am still trying to figure out if what I have is the latest version. Any suggestions on how to determine this? All I know is the guy I hired to work on my computer said it was a pretty hot card. Unfortunately I don’t know what he is basing this on.

Thanks again,
BWSwede


#11

Looks like a Graphics Card problem.

Open Control-Panels > NVIDIA…
In the front page, ensure that the 3d-application can decide on the settings used…

Try adjusting permutations of the OpenGL settings in SketchUp’s Preferences…

To so out your Graphics card driver…
Open Control-Panels > Device Manager
Find Display Adapters > NVIDIA GeForce 9500 GT
Select, right-click > context-menu > Update Driver Software… > Search…
It searches the Internet and installs any updates… if available…

Restart SketchUp to allow changes to take effect…


#12

Thanks TIG,

Explaining what to do was a big help. Unfortunately it came back saying there isn’t any other software to install.

I don’t understand why when I make the image into a pdf I still see the goofed up text label but when I do a print screen and make a jpg that it looks ok when I look at it on this forum.

I need to get this figured out. Do you have any other ideas?

Thanks again,
BWSwede


#13
NVIDIA GeForce 9500 GT
  1. Go here http://www.geforce.com/drivers and let the site detect your GC, then find if there’s an available newer driver, if so download and install it… Sometimes a Device check says it’s OK, while the site says there’s an update to get…

  2. Have you checked the NVIDIA control-panel’s settings, like I suggested earlier - ‘let the 3d app decide’…

  3. If/when you do have the latest GC driver installed then do what I said before about opening SketchUp > Preferences > OpenGL.
    There are several options which you can tick/untick etc - switching some off/on in different combination + OK, might reveal what you need to have set to avoid this issue…


#14

TIG - Thank you for your help and patience.

I went to geforce to use their auto-detect but it said I needed to install Java. I installed Java (install verified), restarted the browser, and tried the auto-detect again and it still says I need to install Java.

I went to NVIDIA control panel and looked all over the place but did not see any thing about “let the 3d app decide”.

I went to Sketchup and unclicked all 3 boxes in Preferences OpenGL. Opened up a SU drawing and it now appears to work. I don’t see the box above the text as I had seen earlier. Success! (?) I hope so.

Thanks again for your help. I really appreciate it.

BWSwede


#15

Here’s mine…


Maybe you need to restart your browser or change your Internet Options to allow Java to run in the driver checker ?


#16

Thanks for the image. I found it and “let the 3D application decide” was already checked.

I am going to assume everything is fine now. I just hope that by unchecking 2 of the 3 boxes in OpenGL that something else doesn’t get affected and start giving me issues.

Thanks again,
BWSwede


#17

Ideally, Hardware acceleration should be enabled in SU for best performance. Try disabling fast feedback. You should be able to model OK without that

On the NVIDIA site, did you try to look up the driver by the graphics card model number instead of auto-detect?


#18

I did a manual search on the NVIDIA site and found 4 drivers newer than mine. Two of them are beta versions. Should I just download the newest non-beta one? If I do that will it load itself and get rid of the old version automatically?

I’ll try enabling hardware accelration in SU and see if my issue comes back.

Thanks,
BWSwede


#19

You need to download, start the installer if it doesn’t start automatically, and click the Install button. Yes, installing a new version removes the old one.

Anssi


#20

Thanks Anssi, I started to do the install and 1/2 through the process I received a message from Microsoft stating the install does not pass the Windows Logo testing and that it was highly recommended I stop the install or risk damage to my operating system now or in the future. It was a pretty scary warning so I stopped the install.

BWSwede