Inferencing: does zooming in stop it? (+ some other questions)

I did a shadow study yesterday, and I needed to calculate the area that was left unshaded for each of the hours in question. I knew there would be an extension to turn shadows into geometry (this one), but I was under the gun and didn’t have time to d/l it from sketchucation and test it, so I just did it by eyeballing it and making geometry that way to get an area. I’ll explore the extension later, but I just want to understand a few things.

I turned off “Enable length snapping” and changed to mm from m for units and zoomed right in, but I still seemed to get inferencing happening from points that I could have sworn were off screen. 1) Is that possible and 2) if so, is it because of SU’s inferencing “touch memory”? To get around it, I dragged out construction lines to cross at the points I was trying to target with the line tool, as they seemed to have less interplay with the inferencing system. It was pretty laborious, and again I’ll look at the shadow extension, but I’d like to understand what was going on.

Recapping and adding:

  1. Can you still get inferencing from stuff off screen?
  2. Is so, does it bias towards SU’s “touch memory”?
  3. Does making things hidden (either by Hide or turning off their visibility in tags) stop inferencing from those entities?

Thanks in advance.

That would have no impact on inferencing. That only affects the display of the dimensions.

I’ve never seen Sketchup inference to off screen geometry. Zooming in would be a way to limit help get away from some inferencing points because they’d be off screen.

It would help to turn off tags for objects you don’t need to see or you could hide them. If you are working inside a group or component you could turn tick the box for Hide rest of Model in Model Info>Components. That could be faster than manually hiding or turning off tags.

What puzzled me was that even though I turned off length snapping, it still seemed to be doing it somewhat, and in a hail mary I changed the units and it helped. Do I need to exit and restart the app for the settings to take, or should it happen straight away?

Thanks, I’d trust your experience rather than mine. It must have been on screen. I could have sworn it wasn’t, but I was racing the clock and could have been mistaken. I’ll fiddle around more and see if I can recreate it.

Thanks again.

How do you imagine this effects the inferencing engine?

No. Turning off Length Snapping is good although it isn’t really part of the inferencing. It results in some non-inferenced snap points, though. Few experienced users leave Length Snapping enabled.

Dimension units and precision only affects the display of dimensions, though. They have nothing to do with inferencing or even how accurate your model is.

Good luck. The less you have on screen in a situation like this, the better.

Not the inferencing engine itself, but I added that I turned it off to establish that it wasn’t length snapping preventing me from drop line end points at the edges of the eyeballed shadows, but (as announced on screen as I was doing it) the inferencing engine itself. Again, it must have been something on screen that I wasn’t noticing.

Got it, that makes sense. I can see how that might be tricky to get perfect, as the shadows themselves won’t inference of course. I believe the inference engine will reference (not snap to) items off screen with axis lines if you have called attention to them previously with a hover, so perhaps you were seeing that? Or it must have been something not seen.

And perfect it wasn’t! (no fault of SU), but close enough. In the future I’ll use the plugin. It will save a hell of a lot of time if it works the way I think it does.

1 Like