Inference hidden components


#1

Is it normal for SU to inference geometry of components that are hidden in a currently visible layer?


#2

Only if View Hidden Geometry is on.

-Gully


#3

I am seeing inferencing only to vertices within hidden groups.

It does not seem to matter whether the group or the primitives (or both,) are on a hidden layer.


#4

(about SketchUp 2015)
No, I don’t think you should see any inferencing with hidden grouped geometry, nor with grouped geometry on layers that are not visible. The groups are separating their geometry from other geometry in the model. The whole (/one of the) idea(s) to hide groups/components or put groups/components on hidden layers is to (with grouping of course) make them (temporarily) invisible as separate entities. If this weren’t the case, how would you be able to temporarily reduce the amount of inferencing geometry to ease working in complex models.

In any case I can see inferencing popping up to only one orb two endpoints, the one(s) I hovered over last in a not yet hidden group or, due to hidden layer, in a previously visible group. To me it seems that SketchUp soon loses “contact” with this hidden/invisible geometry after one or two different operations. Just like with previous SketchUp versions.

What do others experience?


#5

Yes, that was what was happening. I was inferencing vertices within a hidden group (actually a component) on a currently visible layer and was not expecting SU to do so. It was some of the last geometry that I was inferencing before I hid the group. I thought it may be happening because I had been inferencing these vertices so i saved the file, restarted SU, and it still inferenced the hidden vertices on the currently visible layer. I was not set to view hidden geometry at anytime. Again, it was a hidden component on a visible layer. I did not know if this was to be expected or a bug.


#6

I think it should be considered a bug.


#7

Today, inferencing edges in a group on a non-active layer. Do I need to report this as a bug, at some specific location?


#8

If the entity is visible, even on a non-active layer, then it should inference. That would not be a bug.

SketchUp does not have Frozen layers like AutoCAD does. In fact it does not have Lockable layers, only lockable entities.


#9

Hi @Wo3Dan,
Normal Inference Engine behavior is what I see too.
The Inference Engine dynamically retains a certain number of previous inference points.
If the geometry is subsequently hidden those previous inferences briefly remain in focus.
That is, until user actions shift inference focus to other things.


@chopdog
In a way, the term “a non-active layer” suggests you might not fully understand SketchUp’s layer system.
Improper use of SU’s layering scheme often leads to unexpected model behavior.
The default Layer0 should (must) always be the active/current layer.

Does SketchUp Support Layers? —SketchUp Knowledge Center


#10

Hi @chopdog,

I just ran into the inference/snapping behavior on hidden (and not-visible) geometry. I know this is an old thread, but if the problem persists…why not this discussion? Besides, this is certainly a “feature” worth noting…

Here’s a hack to get the expected inference functionality: create a new to-be-hidden layer, then move the geometry that you wish to hide onto this layer. Once transferred to the new layer, the geometry can be hidden if you toggle off its layer’s visibility.

Hope that helps someone!

(ICYDK - A geometry’s layer can be changed in the Entity Info box. If the geometry includes a group, you will have to open the group, then move all of its geometry to the new layer, as well. Group geometry doesn’t inherit the group layer specification–another “feature”!)


#11

This is a sure sign you are using layers incorrectly, and is probably the cause of the issue described by the OP.
Only Groups and components should be assigned a layer tag, all raw geometry must remain on Layer0 and layer0 should always (unless you understand fully what you are doing) be the active layer.
I’d suggest you read up on Layers in the help files.


#12

Hmm. I seem unable to reproduce the bug I ran into last night that prompted this comment. Namely, I had created geometry on one layer, grouped it, then copied and moved the group to another layer. When I toggled off the visibility of the second layer, both the original geometry and its copy were still visible. I confirmed that the copied group was on the invisible layer, but the geometry in the group was still on the first layer. I thought that was why the geometry remained visible…Anyway, today the copied geometry is hidden when the layer that its parent group is on is toggled invisible, as I assumed it should. Thanks @Box for making me check myself.

tl;dr: Ignore my parenthetical comment above.


#13

Also, the OP’s issue was with hidden geometry being inferenced (even on Layer0), a bug that still persists.


#14

Could you upload a model that shows this ‘bug’ please.


#15

Hidden objects are not inferenced, but objects, especially raw geometry, on hidden layers interact with visible ones.


#16

The ‘bug’ is considered “normal inference engine behavior” according to @Geo:

However, I would argue that if a user toggles hidden geometry visibility off, she expects all reference to that geometry to go away. Certainly it’s bizarre when a tool snaps to invisible points. The engine could remedy this by flushing stored inferences when visibility is turned off. It works with layers anyway!

Just my two cents. I’d love to hear an example of how this “feature” could be leveraged. Challenge accepted, anyone?


Clearing Inferences to Hidden Geometry
#17

I’m sorry but the challenge was to show an example of this ‘bug’.
This thread is from 2 years ago and I’m not seeing a reason yet to resurrect it.


#18

@JoutlawPhysics, It is fair to consider this as a feature request, but it needs to be copied and pasted, as a new linked topic in the SketchUp > Feature Requests category.

To do this, temporarily copy whatever text you want (from your above posts) to the clipboard (or a text editor,) then go to either the original post or bottom of this thread, click the “chain” (Share) link button, and then (from the link popup panel) the “+ New Topic” (Reply as new linked topic) button.
When the new topic form appears, use the category dropdown control to switch category to the SketchUp > Feature Requests category.
Then add the nice concise topic title.
And paste your text from the clipboard (or where ever) into the new topic form’s post body box, and edit or elaborate as needed.


#19

@Box, here’s a screen cap of me reproducing the bug: https://youtu.be/b7O6Bh86Rs0


#20

You should upgrade to the most recent release (2017).

A bunch of work was done to the inferencing engine. I tried to reproduce what your video showed, but could not make it happen.