Inconsistent Undo

undo

#1

I have often come up against a situation where ctrl+z stops working. I have both Ctrl+z and Alt+Backspace shortcuts attributed to undo, but sometimes they both stop working and not even going into the drop down menu works either. It appears to be very random when it stops.

Anybody else have this inconsistency?


#2

Yup, me too, I’m not sure why but have given up trying to find the reason. I just save a whole lot now, often making a copy of certain portions and moving it to another location within the model (as a back-up / fail-safe) before doing complex changes (like with extensions).


#3

Yes I often copy parts of the model to to other areas for separation…


#4

100 undos in the stack…

some actions group steps keeping their stack count short, others don’t…

e.g.
select all 100 edges >> delete == 2 steps
erase 100 edges one by one == 100 steps [ stack is full ]

extensions for ‘some’ renderers are notorious for filling the stack, even when not in use…

but there’re other culprits as well…

john


#5

This seems to be the biggest issue. Extensions allow you to push a button to do what appears to be one thing. However, behind the scenes, 30 steps are actually happening.


#6

thanks @john_drivenupthewall … The last time it happened I wanted to undo the very last operation I had done, which was using the move tool to move a pretty simple face which had some auto folding related to it… Does that still come under what you mentioned above?


#7

that sounds like extensions removing and/or adding data to every face and edge as they move…

step one would be the move tool, and it gets buried deeper with each ‘write’…

if you look at Edit Undo, it may help you pinpoint what’s adding to the stack…

john


#8

Understood and fair enough, however I’ve had times where a simple eraser delete of but a few faces / lines (seriously little) would undo only into random selection of what was erased or not at all. It isn’t limited to that function either though…


#9

also remember that some of you guy’s and gal’s have many extension all doing this at the same time…

they only need a one each and bam, your last actual action is buried…

I have NO extensions enabled unless I actively need to use them as my next tool…

I only have Toolbar Buttons, Menu Items, Shortcut Keys for extensions that ‘Lazy Load’ i.e. lay dormant until activated with the click…

john


#10

And does that actually reduce the funny undo business to almost zero?


#11

I don’t have many ‘funny’ undo’s unless using DC’s or testing extensions, it’s one of the worst offenders…

I also try to Save before getting close to 100, so I can use revert if I get caught out going to many steps…

you could set them higher, but memory suffers more and the key was moved since I last did that…

john


#12

Thanks John, Where can I find info and learn about on seeing the number of undos? Is it a console thing I’d have to learn?


#13

on a mac they are set in a plist…


		<key>MaxUndo</key>
		<integer>100</integer>

but on windose???

I don’t know of any easy way to monitor the stack, but a save is the only thing that clears it fully…

john


#14

thanks… yes I’m on Windows


#15

In SketchUp 2018 on Mac the setting migrated to the SharedPreferences.json file. This might also be true on Windows? @IanR your profile doesn’t say what version of SketchUp you are using.


#16

@slbaumgartner , that’s from my v18 ,plist…

they must be in both?

john


#17

Yeah, I’ve spotted numerous settings that are replicated in both the jsons and the plist. I don’t know why, nor which one takes precedence.


#18

profile updated, thanks for the heads up