Inconsistent "Save As" behavior, Scenes won't make Untagged invisible

Two bugs with SketchUp Pro 2020 (20.2.171):

"Save As" opens a different directory when invoked using the menu versus the shortcut key. If I use command-shift-S, I am taken to the directory where I opened the current working file. If I use the menu, I am take to Documents (or presumably the default location for all models). This is almost a good thing, but the former behavior should be the default.

Scenes won’t make Untagged objects invisible. That is, if I make Untagged objects invisible and save (or resave) a scene, upon clicking on the scene in the Scenes window, Untagged becomes visible once more. This should be possible (and was in prior versions), but it doesn’t seem even remotely reasonable that this is not saveable.

I tried to reproduce these in 2021 in Mac, but was unable to do so…

I guess I’m late to updating then! I subscribed but haven’t downloaded the latest version. I like to be a little late because of the tools that don’t get instantly updated after each release. Will get back on this.

Okay, so I just upgraded to 2021 (21.0.392). The Save As bug is still there, and so is the Untagged problem in Scenes.

Should also add I am running this on MacOS Big Sur (11.2.3).

Odd… anyone on here seeing this?

1 Like

I can see this too, the menu ‘Save As’ refers to set files location in the Preferences, whereas the shortcut begins in the location that the current file is actuallyin.

the other, I cannot reproduce. What are the settings in the scene?

EDIT: Btw, I see this also in lower versions, (2017) can’t remember the exact workings when I was on another OS (current: 11.2.1)

1 Like

Do you update the style as well as the scene!

How are you exactly saving a scene?

The accurate way is to use advanced scene settings in scene manager.

The most common way is by updating scenes either on the circular arrows of the scene manager or by right clicking on scene tab and update.

If, in advanced scene settings you have the tags box unticked, it wouldn’t save with an update scene command. If this box is ticked or not can also be checked on the pop up that shows up when you hit the circular arrows on scene manager.

No, I do not. Why is Styles relevant?

I am saving a scene by going to the Scenes window, right clicking on the individual scene, clicking Update Scene, and then clicking Update.

Try doing it like this. Find advanced scene settings and check if all scene properties are ticked on. A property that is unticked in a scene, means it is not saved in that scene. Check whats happening with tags. They should be on. If they are off, activate the tags you want to see and hude an tick tbe tags box. That saves current active tags to scene.

If this doesnt help, your model might be badly organized in terms of groups and their tags.

Check that you are using Tags correctly, you can’t hide untagged unless you have made another Tag active, that’s ok as long as you know what you are doing.

I think what you really should do is never hide untagged. It’s the only layer that you should never hide as it’s a special layer: the only neutral one. You could probably do what you want by hiding other layers and that’s what you should try doing instead.

2 Likes

Are you using an extension like Default Layer Geometry? That would insist on making Untagged the current tag, and, turning it on in the process.

I am using Auto Invisible Layer, but not Default Layer Geometry. I guess I could turn off all my extensions and see if it makes a difference.

Given that the standard advice (from what I can tell) is that you should NEVER draw on any layer other than Untagged, this seems … wrong?

Hi. I don’t understand what you mean exactly.

The best method to control tags is this:

  • Model in untagged;
  • Organize resulting faces and edges into groups and components
  • Assign Tags to those groups and components.
  • Manage tag visibility with scenes.