Include materials as part of component

Hi all,

First of all, what a great community this is. I’ve recently started working in SketchUp.
I’ve created a model where I gather nice materials that I use across multiple models.
These materials are primarily images (jpeg) that I’ve set ‘use as material’. Works perfectly fine.

However, I would like to create a component that contains als of these materials so it is easy to share the materials and easy to import into a new sketchup model.

I’ve selected all of the materials and then created a component. However, if I import this component, the materials are not automatically added to the model.

Anyone got any idea how to fix?

You could always just save the materials…

As for the component, how are you saving it? Are you right clicking on the component , then choosing Save As to export the file?

If i understand your question right…
So far as I remember, few years back, I did create very small squares inside the component at a place where the will be never visible and fill each square (or cube’s) with a color or material. Not sure if I did group them. This way they will not get purged. This way, in a cube you can save 12 colours / materials.

However name them individualy in a way that they have are clear meaning in your material list. I did label them with “cmp_cabinet_<‘material’>”

Or create a single component with all the colours you need in all your components, that way you have a universal colour scheme.

Correct, that is the way I save the component.

Maybe to add what I have done is the following:

  1. Drag image from desktop into Sketchup
  2. Right click the image and “set as material” - the material shows op in the material list
  3. Repeat for all images I want to use as materials
  4. Select all images, right click and create component
  5. Select component, right click and save component
  6. uploaded the component to 3dwarehouse
  7. downloaded component into file I want to use it

Now here is the problem, the component loads into the model. But materials are not showing up in the materials list.

Is this in SketchUp Free (web) as your profile indicates you are using?

Please share a link to one of your Warehouse components.

Instead of ‘set as material’ choose Explode, then do the rest of the steps.
The current steps you follow will create the new component also with Images, instead of faces with materials.

This is the link:

I’m using the free version of SketchUp 2017 (the Mac version)

Please correct your profile then. It says you are using the web version. The instructions for what you need to do is different between the web version and 2017 Make.

Why not save the materials as a local collection for later use? Once you have the materials in your model, go to the In Model materials in the Colors panel. Click on Duplicate and give the collection a useful name. For future models you’ll be able to open that collection in the drop down list at the top of the Colors panel. No need to go to the Warehouse and import all of those materials into your models.

1 Like

When I just drag a graphic from the desktop, the resulting material may be too big. I have to then resize it by guessing at the best dimensions in the material browser. So though drag and drop may be cool, it seems if you apply as a material from the import dialog, you can apply it to a face of the appropriate size, either for an exact sizing or eyeballing the appropriate scale.

Any other methods?

My preference is to draw a rectangle with at least one dimension that matches the dimension of the material. So if I have an image of a board that is 8 feet long, I draw a rectangle that is 8 feet long. Then I use File>Import and import the image as a texture which I apply to the rectangle clicking at the lower left corner and then on the edge at the known dimension. It’s immediately a material and it’s immediately the correct size.

Agree with Dave R . Since materials in the model bloat the model size and performance and clutter of the material browser, I wouldn’t import a bunch at a time–just material by material.

That’s sort of what I was describing, though for stone etc, I might just apply to a wall face in the model and gauge an approximate size

Another option for a material that is already imported, is to then apply it to the correct sized face, position and scale it to be perfect, then right-click Make Unique Texture. Make sure you only have the face selected and not its edges.

You now have a texture that is just big enough to do the job, and you can purge the original texture, that may well have been a lot bigger than it needed to be.

seems also like a good solution

You mean scale with Texture / Position? Yes that would be good for those already imported.

I was thinking of importing methods to save steps though (and it seems drag and drop creates more steps).

Importing and sizing to a face, leaves the original bitmap at it’s potentially huge size. Whether you get that far by import or drag and drop, the make unique steps and purging the original should save some file space and memory usage.

It could in some cases increase the amount of file space and memory, but given that we’re all using 8 megapixel or higher cameras, that’s more than a 300 dpi US Letter sized image. If it’s to be a tiled set of bricks, for example, you could get away with a much smaller image.

You also could make several custom smaller textures out of one single large image.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.